Prime Distance

题目描述:

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

输入:

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

输出:

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

样例输入:

2 17
14 17

样例输出:

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

题目大意:

给出一个区间[L,R], 范围为1<=L< R<=2147483647,区间长度长度不超过1000000

求距离最近和最远的两个素数(也就是相邻的差最小和最大的素数)

code:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
using namespace std;
const int maxn=1e6+10;
const long long maxx=9999999999;
long long prime[maxn];
long long ans[maxn];
int visit[maxn];
long long cnt=0;
void getprime()
{
	memset(prime,0,sizeof(prime));
	memset(visit,0,sizeof(visit));
	for(int i=2;i<maxn;i++)
	{
		if(visit[i]==0)
		{
			prime[cnt++]=i;
			for(int j=i+i;j<maxn;j+=i)
			{
				visit[j]=1;
			}
		}
	}
	visit[0]=visit[1]=1;
}//因为数据量太大,先筛较小的
void findd(long long l,long long r)
{
	memset(ans,0,sizeof(ans));
	for(long long i=0;i<cnt;i++)
	{
		long long b=l/prime[i];
		while(b*prime[i]<l||b<=1)b++;
		for(long long j=b*prime[i];j<=r;j+=prime[i])
		{
			if(j>=l)ans[j-l]=1;
		}
	}
}//筛该区间的大数字
long long temp[maxn];
int main()
{
	getprime();
	long long r,l;
	while(~scanf("%lld%lld",&l,&r))
	{
		if(l==1)l=2;
		long long num=0;
		findd(l,r);
		for(long long i=0;i<=r-l;i++)
		{
			if(ans[i]==0&&i+l<=r)
			{
				temp[num++]=i+l;
			}
		}
		long long big=0,xiao=maxx;
		long long sx,sy,sa,sb;
		for(long long i=1;i<num;i++)
		{
			long long cha=temp[i]-temp[i-1];
			if(cha>big)
			{
				big=cha;
				sx=temp[i-1];
				sy=temp[i];
			}
			if(cha<xiao)
			{
				xiao=cha;
				sa=temp[i-1];
				sb=temp[i];
			}
		}
		if(xiao==maxx)printf("There are no adjacent primes.\n");
		else printf("%lld,%lld are closest, %lld,%lld are most distant.\n",sa,sb,sx,sy);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值