1129. Recommendation System (25)

1129. Recommendation System (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (<= 50000), the total number of queries, and K (<= 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i = 1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:
12 3
3 5 7 5 5 3 2 1 8 3 8 12
Sample Output:
5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

提交代


题目大意:

输入一个数据之后马上遍历它前面的数据,依次输出出现次数最多的数,次数相同则输出小的那个数,最多输出三个。

解题思路:一开始的时候想着用结构体储存再排序,但每次排序之后原来的数据就被打乱了,再储存的时候就出现了问题。后面问了同学,同学说别用vector试着用set试试,set里面可以查找和删除,顿时明白过来了,用set试了一下,一遍就过了。下面是具体的思路。

我们需要定义一个结果日存储出现的数据和出现的次数。直接在里面用一个重载进行排序。先按次数从小到大,再按数据从小达到。最关键的地方到了。每次到set中查找刚刚输入的数据是否在set中出现过,出现过就把它删除,更新一下出现的次数,重新插入放回去。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<set>
using namespace std;
struct node{
	int num;
	int cnt;
	node(int y,int x):cnt(x),num(y){}//结构体的初始化
									//重载操作,比在外面写一个函数更方便 
	bool operator < (const node &x)const{
		if(cnt==x.cnt){
			return num<x.num;
		}else{
			return cnt>x.cnt;
		}
	}
};
int main(){
	int n,m;
	int book[50005];
	set<node> Q;
	// freopen("input.txt","r",stdin);
	set<node>::iterator ite;
	memset(book,0,sizeof(book));
	scanf("%d%d",&n,&m);
	for(int i = 0;i < n;i++){
		int a;
		scanf("%d",&a);
		book[a]++;
		if(i>0){
			int sum = 0;
			printf("%d:",a);
			//注意一下,sum必须小于m,而且不能超过set中数据的范围 
			for(ite = Q.begin();sum<m&&ite!=Q.end();ite++){
				printf(" %d",*ite);
				sum++;
			}
			printf("\n");
		}
		//查找该节点是否出现过,如果出现过就把它删除再重新插入 
		ite = Q.find(node(a,book[a]-1));
		if(ite!=Q.end()){
			Q.erase(ite);
		}
		Q.insert(node(a,book[a]));
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值