7-14 电话聊天狂人

7-14 电话聊天狂人(25 分)

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:

输入首先给出正整数N105),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:

在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832

输出样例:

13588625832 3

#include<iostream>
#include<cstring>
#include<string>
#include<cstdlib>
#include<malloc.h>
using namespace std;
typedef struct node *pos;
typedef struct node{
	int cnt;
	pos next;
	char phone[12];
}*List;
typedef struct Hashtable{
	int tablesize;
	List *tablelist;
}*HashTable;
int nextprim(int x){
	int i,j;
	for(i = x;;i++){
		for(j = 2;j*j <= i;j++){
			if(i % j==0)break;
		}
		if(j*j>i){
			return i;
		}
	}
} 
HashTable init(int size){
	int Tsize = nextprim(size);
	HashTable H = (HashTable)malloc(sizeof(Hashtable));
	H->tablelist = (List*)malloc(sizeof(List)*Tsize);
	H->tablesize = Tsize;
	for(int i = 0;i < H->tablesize;i++){
		H->tablelist[i] = (List)malloc(sizeof(node));
		H->tablelist[i]->next = NULL;
	}
	return H;
}
int Hash(int key,int tsize){
	return key%tsize;
}
List Find(char key[],HashTable H){
	List t,tmp,p;
	t = H->tablelist[Hash(atoi(key+6),H->tablesize)];
	p = t->next;
	while(p!=NULL&&strcmp(key,p->phone))
		p = p->next;
	return p;
}
void insert(char key[],HashTable H){
	List t,tmp,p;
	p = Find(key,H);
	t = H->tablelist[Hash(atoi(key+6),H->tablesize)];
	if(p == NULL){
		tmp = (List)malloc(sizeof(node));
		strcpy(tmp->phone,key);
		tmp->cnt = 1;
		tmp->next = t->next;
		t->next = tmp;
	}else{
		(p->cnt)++;
	}
}
void print(HashTable H){
	List t;
	char minphone[12];
	int maxn = -1,sum = 1;
	for(int i = 0;i < H->tablesize;i++){
		t = H->tablelist[i];
		t = t->next;
		while(t != NULL){
			if(t->cnt > maxn){
				maxn = t->cnt;
				strcpy(minphone,t->phone);
				sum = 1;
			}else{
				if(t->cnt == maxn){
					if(strcmp(minphone,t->phone)>0){
						strcpy(minphone,t->phone);
					}
					sum++;
				}
			}
			t = t->next;
		}
	}
	printf("%s %d",minphone,maxn);
	if(sum>1) printf(" %d",sum);
	printf("\n");
}
int main(){
	int n;
//	freopen("input.txt","r",stdin);
	char s1[12],s2[12];
	scanf("%d",&n);
	HashTable H;
	H = init(n*2);
	for(int i = 0;i < n;i++){
		scanf("%s%s",s1,s2);
		
		insert(s1,H);
//		printf("%s %s\n",s1,s2);
		insert(s2,H);
	}
	print(H);
	return 0;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值