HDU 2647 Reward【拓扑排序】

33 篇文章 0 订阅

Reward

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 44   Accepted Submission(s) : 24
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.

Output

For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.

Sample Input

2 1
1 2
2 2
1 2
2 1

Sample Output

1777
-1

Author

dandelion

Source

曾是惊鸿照影来

注意:用的广搜,所以只需要每次dis[i]=0时确定flag并入队列即可!!!(广搜情况下,不同reward相当于处于不同层次,只要dis不是零,
就说明 再次遇到他时,已处于更高的层次)

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
typedef long long LL;
const int INF =0x7FFFFFFF;
const int low(int x){return x&-x;}

const int M=10000+1;
int dis[M];
int flag[M];
vector<int>s[M];
int i,j,n,m,k,t;

int Topo()
{
    queue<int>Q;
     rep(i,1,n+1)
      if(!dis[i])
        Q.push(i),flag[i]=888;
      int num=0;
    while(!Q.empty())
    {
        int cur=Q.front();
        Q.pop();
        num++;
        rep(i,0,s[cur].size()){
            dis[s[cur][i]]--;
            if(!dis[s[cur][i]]){
              Q.push(s[cur][i]);
              flag[s[cur][i]]=flag[cur]+1;
            }
        }
    }
    if(num<n)return 0;
    return 1;
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        MS(flag,0);
        MS(dis,0);
        rep(i,0,n+1)s[i].clear();
        rep(i,0,m){
            int a,b;
            scanf("%d%d",&a,&b);
            s[b].push_back(a);
            dis[a]++;
        }
        if(!Topo()){
            printf("-1\n");
            continue;
        }
        int sum=0;
        rep(i,1,n+1)
          sum+=flag[i];
          printf("%d\n",sum);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值