hdu 2647 Reward 拓扑排序。

154 篇文章 1 订阅
50 篇文章 0 订阅

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4599    Accepted Submission(s): 1400


Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
 

Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 

Sample Input
  
  
2 1 1 2 2 2 1 2 2 1
 

Sample Output
  
  
1777 -1
 用的前向星储存方式,,用其他的害怕超内存。
储存时注意方向,
否则拓扑排序的顺序就会弄反了。
代码:
#include <stdio.h>
#include <string.h>
#define MAX 10010
int in[MAX] ;
int head[MAX] , t[MAX];
bool visited[MAX] ;
struct Edge{
	int to , next ;
}edge[MAX<<1];
int main()
{
	int n , m;
	while(~scanf("%d%d",&n,&m))
	{
		memset(head,-1,sizeof(head)) ;
		memset(in,0,sizeof(in)) ;
		memset(visited,false,sizeof(visited)) ;
		int d = 888 , sum = 0 ;
		for(int i = 1 ; i <= m ; ++i)
		{
			int x, y ;
			scanf("%d%d",&x,&y) ;
			edge[i].to = x ;
			edge[i].next = head[y] ;
			head[y] = i ;
			in[x] ++ ;
		}
		bool flag = true ;
		int i = n ;
		while(i>0)
		{
			int cnt = 0 , index = -1;
			for(int j = 1 ; j <= n ; ++j)
			{
				if(!visited[j] && in[j] == 0)
				{
					visited[j] = true ;
					sum += d ;
					t[cnt++] = j ;
					--i ;
				}
			}
			if(cnt == 0)
			{
				flag = false ;
				break ;
			}
			for(int j = 0 ; j < cnt ; ++j)
			{
				for(int k = head[t[j]] ; k != -1 ; k = edge[k].next)
				{
					--in[edge[k].to] ;
				}
			}
			++d ;
		}
		if(flag)
			printf("%d\n",sum) ;
		else
			puts("-1") ;
	}
	return 0 ; 
}

与君共勉
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值