CSU 1809 Parenthesis【湖南省第十二届大学生计算机程序设计竞赛 G题】

1809: Parenthesis

Time Limit: 5 Sec   Memory Limit: 128 MB
Submit: 874   Solved: 253
[ Submit][ Status][ Web Board]

Description

Bobo has a balanced parenthesis sequence P=p 1 p 2…p n of length n and q questions.
The i-th question is whether P remains balanced after p ai and p bi  swapped. Note that questions are individual so that they have no affect on others.
Parenthesis sequence S is balanced if and only if:
1. S is empty;
2. or there exists  balanced parenthesis sequence A,B such that S=AB;
3. or there exists  balanced parenthesis sequence S' such that S=(S').

Input

The input contains at most 30 sets. For each set:
The first line contains two integers n,q (2≤n≤10 5,1≤q≤10 5).
The second line contains n characters p 1 p 2…p n.
The i-th of the last q lines contains 2 integers a i,b i (1≤a i,b i≤n,a i≠b i).

Output

For each question, output " Yes" if P remains balanced, or " No" otherwise.

Sample Input

4 2
(())
1 3
2 3
2 1
()
1 2

Sample Output

No
Yes
No

HINT

Source

  令‘(‘表示1,‘)‘表示-1,例如((()(为 1 1 1 -1, 根据合法括号的定义,(总是要比)多或者相等,就是说,前缀和必须总是>=0(对于每一个位置必须都要>=0, 最后一个必须等于0。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
typedef long long LL;
const int INF=0x7ffffff;

const int M=1e5+1;
int a[M],b[M];
char s[M];
int i,j,k,n,m,q;

int main()
{
    while(~scanf("%d%d",&n,&q))
    {
        scanf("%s",s);
        for(i=0;i<n;i++){
            if(s[i]=='(')a[i+1]=1;
            else a[i+1]=-1;
            b[i+1]=b[i]+a[i+1];
        }
        for(i=0;i<q;i++){
            int x,y;
            scanf("%d%d",&x,&y);
            if(a[x]==a[y]){printf("Yes\n");continue;}
            if(x>y)swap(x,y);
            bool flag=1;
            int ans=b[x-1];
            ans+=a[y];
            if(ans<0)flag=0;
            else for(j=x+1;j<y;j++){
                ans+=a[j];
                if(ans<0){flag=0;break;}
            }
            ans+=a[x];
            if(ans<0)flag=0;
            if(flag)printf("Yes\n");
            else printf("No\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值