POJ - 3273 Monthly Expense 【二分:】

Monthly Expense
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 26423 Accepted: 10162

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers:  N and  M 
Lines 2.. N+1: Line  i+1 contains the number of dollars Farmer John spends on the  ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500


Point:

当kk<=k时表示可以继续被分成更小组合的

刚开始因为ub,lb给的太严格,二分的方法又不够严谨,所以一直错

#include<iostream>  
#include<cstdio>  
#include<cstring>  
#include<string>  
#include<cmath>  
#include<queue>  
#include<stack>  
#include<vector>  
#include<map>  
#include<algorithm>  
using namespace std;  
#define ll long long  
#define ms(a,b)  memset(a,b,sizeof(a))  
const int M=1e5+10;  
const int inf=0x3f3f3f3f;  
const int mod=1e9+7; 
int i,j,k,n,m; 
int a[M]; 
int b[M];
double y[M];

bool check(int mid)
{
	int sum=0;
	int kk=1;
	for(int i=0;i<n;i++){
	    sum+=a[i];
		if(sum>mid){
			sum=0;
            i--;
			kk++;
		}
	}
	if(kk<=k)return true;
	return false;
}

int main()
{
	while(~scanf("%d%d",&n,&k)){
		int lb=-1,ub=0;
		for(int i=0;i<n;i++){
			scanf("%d",&a[i]);
			lb=max(lb,a[i]);
			ub+=a[i];
		}
		while(ub>lb){
			int mid=(lb+ub)/2;
			if(check(mid))ub=mid-1;
			else lb=mid+1;
		}
		printf("%d\n",lb);
	}
	return 0;
}

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
#define ll long long
#define ms(a,b)  memset(a,b,sizeof(a))
const int M=1e5+10;
const int inf=0x3f3f3f3f;
const int mod=1e9+7;
int i,j,k,n,m;
int a[M];
int b[M];
double y[M];

bool check(int mid)
{
	int sum=0;
	int kk=1;
	for(int i=0;i<n;i++){
	    sum+=a[i];
		if(sum>mid){
			sum=0;
            i--;
			kk++;
		}
	}
	if(kk<=k)return true;
	return false;
}
int main()
{
	while(~scanf("%d%d",&n,&k)){
		int lb=-1,ub=0;
		for(int i=0;i<n;i++){
			scanf("%d",&a[i]);
			lb=max(lb,a[i]);
			ub+=a[i];
		}
		ub++,lb--;
		while(ub-lb>1){
			int mid=(lb+ub)/2;
			if(check(mid))ub=mid;
			else lb=mid;
		}
		printf("%d\n",ub);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值