动态规划专项练习二

  动态规划专项一链接:https://blog.csdn.net/QAZJOU/article/details/120691074?spm=1001.2014.3001.5501
今天1024程序节,所以祝愿不要秃头哈(bushi)
最近的算法题有些拖了哈,不少小伙伴开始催更了,下面阶段将会同时开辟leetcode题库练习。事情比较多哈,因为要学web前端,故学习了java(快结束了,到时有空路线安排出来看),等过几天将java笔记上传出来。(写了那么的C/C++,C++写算法还是不错的,而java的图形化和可视化做的还是还是蛮好的啊)
现在进行练习二,以此巩固,这次的题型以函数为主,(题源ACM和NEFU简单题,所以部分为英文版)
题目描述一:We all love recursion! Don’t we?
Consider a three-parameter recursive function w(a, b, c):
if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1
if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)
if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)
otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)
This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.
Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output
Print the value for w(a,b,c) for each triple.
Sample Input
1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1
Sample Output
w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

#include  <iostream>
#include <cstring>
using namespace std;
long long data[21][21][21];


long long inf(int x,int y,int z){
    if(x<=0||y<=0||z<=0) return 1;
    if(x>20||y>20||z>20) return inf(20,20,20);
    if(x<y&&y<z){
        if(data[x][y][z]==-1){
            data[x][y][z]=inf(x,y,z-1)+inf(x,y-1,z-1)-inf(x,y-1,z);
            return data[x][y][z];
        }
    }
    else{
        if(data[x][y][z]==-1){
            data[x][y][z]=inf(x-1,y,z)+inf(x-1,y-1,z)+inf(x-1,y,z-1)-inf(x-1,y-1,z-1);
        }
    }
    return data[x][y][z];
}


int main(){
    int x,y,z;
    while(cin>>x>>y>>z){
        if(x==-1&&y==-1&&z==-1) break;
        memset(data,-1,sizeof(data));//初始化
        cout<<"w("<<x<<","<<y<<","<<z<<")"<<"="<<inf(x,y,z)<<endl;
    }
    return 0;
}

题目描述二The Recaman’s sequence is defined by a0 = 0 ; for m > 0, a(m) = a(m−1) − m if the resulting a(m) is positive and not already in the sequence, otherwise a(m) = a(m−1) + m. The first few numbers in the Recaman’s Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 · · · .

Given k, your task is to calculate a(k).

#include <iostream>
#include <cstring>
using namespace std;

#define size 500000

int data[size+1];
bool inp[size*10];

int main(){
    int n;
    memset(inp,false,sizeof(inp));
    data[0]=0,inp[0]=true;
    for(int i=1;i<=size;i++){
        if(data[i-1]-i>0&&inp[data[i-1]-i]==false) data[i]=data[i-1]-i;
        else data[i]=data[i-1]+i;
        inp[data[i]]=true;
    }
    while(cin>>n&&n!=-1){
        cout<<data[n]<<endl;
    }
    return 0;
}



题目描述三:每到冬天,資訊學院的張健老師總愛到二龍山去滑雪,喜歡滑雪百這並不奇怪, 因為滑雪的確很刺激。可是為了獲得速度,滑的區域必須向下傾斜,而且當你滑到坡底,你不得不再次走上坡或者等待升降機來載你。張老師想知道載一個區域中最長底滑坡。區域由一個二維陣列給出。陣列的每個數字代表點的高度。
輸入的第一行表示區域的行數r和列數c(1 <= r,c <= 100)。下面是r行,每行有c個整數,代表高度h,0<=h<=10000。
輸出最長區域的長度。

#include <iostream>
#include <cstring>
using namespace std;

int datam[101][101];
int inp[101][101];

int m,n;
int f(int i,int j){
    int max1,max2;
    int max_r=0,max_l=0,max_u=0,max_d=0;
    if(datam[i][j]>0) return datam[i][j];
    if(j+1<=n&&inp[i][j]>inp[i][j+1]) max_r=f(i,j+1);
    if(j-1>=1&&inp[i][j]>inp[i][j-1]) max_l=f(i,j-1);
    if(i+1<=m&&inp[i][j]>inp[i+1][j]) max_u=f(i+1,j);
    if(i-1>=1&&inp[i][j]>inp[i-1][j]) max_d=f(i-1,j);
    max2=max(max_u,max_d);
    max1=max(max_l,max_r);
    datam[i][j]=max(max1,max2)+1;
    return datam[i][j];
}

int main(){
    memset(datam,0,sizeof(datam));
    int k,maxall;
    while(cin>>m>>n){
        maxall=0;
        for(int i=1;i<=m;i++)
            for(int j=1;j<=n;j++) cin>>inp[i][j];
        for(int i=1;i<=m;i++)
            for(int j=1;j<=n;j++) k=f(i,j);
        for(int i=1;i<=m;i++)
            for(int j=1;j<=n;j++){
                if(maxall<datam[i][j]) maxall=datam[i][j];
            }
        cout<<maxall<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值