Function Run Fun POJ - 1579 记忆化搜索

传送门

 题目:

Description

We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1


大致题意:给了递归式,让你剪枝。


解法:用一个三位数组将走过的状态保存起来,记忆化搜索。


代码1:32ms过

#include<stdio.h>
#include<string>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<math.h>
using namespace std;

const int maxn = 100;
int a, b, c, dp[maxn][maxn][maxn];

int dfs(int x, int y, int z)
{
    if(x <= 0 || y <= 0 || z <= 0)
        return 1;
    if(x > 20 || y > 20 || z > 20)
        return dfs(20, 20, 20);
    if(dp[x][y][z])//如果已经搜过,直接返回这个状态。注意这个判断条件不能放在上面,因为可能会数组越界。
        return dp[x][y][z];
    if(x < y && y < z)
    {
        dp[x][y][z] = dfs(x, y, z-1) + dfs(x, y-1, z-1) - dfs(x, y-1, z);
        return dp[x][y][z];
    }
    else
    {
        dp[x][y][z] = dfs(x-1, y, z) + dfs(x-1, y-1, z) + dfs(x-1, y, z-1) - dfs(x-1, y-1, z-1);
        return dp[x][y][z];
    }
}
int main()
{
    while(scanf("%d%d%d",&a,&b,&c) != EOF)
    {
        if(a == -1 && b == -1 && c == -1)
            break;
        memset(dp, 0, sizeof(dp));
        int ans = dfs(a, b, c);
        printf("w(%d, %d, %d) = %d\n", a, b, c, ans);
    }
    return 0;
}


代码2:参考了大神的代码,先打表,0ms过。

#include<stdio.h>
#include<algorithm>
#include<string>
#include<string.h>
#include<iostream>
#include<math.h>
using namespace std;

const int maxn = 25;
int dp[maxn][maxn][maxn];

int main()
{
    for(int i = 0; i < 21; i ++)
        for(int j = 0; j < 21; j ++)
            for(int k = 0; k < 21; k ++)
            {
                dp[i][j][0] = 1;
                dp[i][0][k] = 1;
                dp[0][j][k] = 1;
            }
    for(int i = 1; i < 21; i ++)
        for(int j = 1; j < 21; j ++)
            for(int k = 1; k < 21; k ++)
            {
                if(i < j && j < k)
                    dp[i][j][k] = dp[i][j][k-1] + dp[i][j-1][k-1] - dp[i][j-1][k];
                else
                    dp[i][j][k] = dp[i-1][j][k] + dp[i-1][j-1][k] + dp[i-1][j][k-1] - dp[i-1][j-1][k-1];
            }

    int a, b, c;
    while(scanf("%d%d%d",&a,&b,&c) != EOF)
    {
        if(a == -1 && b == -1 && c == -1)
            break;
        if(a <=0 || b <= 0 || c <= 0)
            printf("w(%d, %d, %d) = 1\n", a, b, c);
        else if(a > 20 || b > 20 || c >20)
            printf("w(%d, %d, %d) = %d\n", a, b, c, dp[20][20][20]);
        else
            printf("w(%d, %d, %d) = %d\n",a, b, c, dp[a][b][c]);
    }
    return 0;
}

如有错误,欢迎指出~

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值