UVA1220Party at Hali-Bula(树形dp)

Description
Download as PDF
Dear Contestant,
I’m going to have a party at my villa at Hali-Bula to celebrate my retirement from BCM. I wish I could invite all my co-workers, but imagine how an employee can enjoy a party when he finds his boss among the guests! So, I decide not to invite both an employee and his/her boss. The organizational hierarchy at BCM is such that nobody has more than one boss, and there is one and only one employee with no boss at all (the Big Boss)! Can I ask you to please write a program to determine the maximum number of guests so that no employee is invited when his/her boss is invited too? I’ve attached the list of employees and the organizational hierarchy of BCM.

Best,
-Brian Bennett

P.S. I would be very grateful if your program can indicate whether the list of people is uniquely determined if I choose to invite the maximum number of guests with that condition.
Input
The input consists of multiple test cases. Each test case is started with a line containing an integer n(1 n 200) , the number of BCM employees. The next line contains the name of the Big Boss only. Each of the following n - 1 lines contains the name of an employee together with the name of his/her boss. All names are strings of at least one and at most 100 letters and are separated by blanks. The last line of each test case contains a single 0.
Output
For each test case, write a single line containing a number indicating the maximum number of guests that can be invited according to the required condition, and a word Yes or No, depending on whether the list of guests is unique in that case.
Sample Input
6
Jason
Jack Jason
Joe Jack
Jill Jason
John Jack
Jim Jill
2
Ming
Cho Ming
0
Sample Output
4 Yes
1 No

收获:
1.窝们发现,对于每一个人选或者不选,只需要考虑他的儿子们有没有被选。 于是就可以从儿子的状态状态转移过来。于是这是一道经典基础树形dp,动态转移方程也很简单。
因为此节点选(1)或不选(0) 只与儿子们的状态有关,满足无后效性。
若选,则儿子节点都不能选,f[father,1]=f[sons,0]。(唯一性)此时只要有一个儿子的wy[son,0]==1(1表示有多种方案),则wy[father,1]==1;
若不选,每个儿子都可选可不选。于是对于每一个儿子,会选择较优的那个方案(最优子结构)。相应地,如果选择的那个方案本身就不满足唯一性 则这个父亲就不会满足唯一性。特别地,如果f[son,0]==f[son,1]那 f[father,0]==1 .
实现嘛,就是通过dfs 递归来实现。给了我们根节点,,就可以从根节点开始搜索。

2.通过这道题,终于让窝尝试了stl map。vector。
map 《string,int》 mp; 建立一个string-》int的映射,即mp[jame]=5;这样下标可以是字符串。感觉特别方便。。。但是怎么实现的不了解,时间复杂度也不了解。。。(今天听大大说,map复杂度是lgn?)
vector 《int》 g;可以直接用 g[mp[a]].push_back(mp[b])..其实相当于开了个二维数组,这道题n《200,是可以开二维数组的。
3.一个深刻的教训 x=++tot 和x=tot++ 的区别,,,导致死循环debug了半天。

#include <cstdio>
#include <iostream>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <cctype> //???
#include <map>
#include <vector>
using namespace std;
const int maxn=300;
map <string,int> mp;
vector<int> g[300];

int fa[300][2],wy[300][2],n;

int dfs(int u)
{
    if (g[u].size()==0)
    {
        fa[u][0]=0;
        fa[u][1]=1;
        return 0;
    }
    fa[u][1]++;
    for(int i=0;i<g[u].size();i++)
    {
        int v=g[u][i];
        dfs(v);
        fa[u][1]+=fa[v][0];
        if (wy[v][0]==1) wy[u][1]=1;
        fa[u][0]+=max(fa[v][0],fa[v][1]);
        if (fa[v][0]==fa[v][1]) wy[u][0]=1;
        if (fa[v][0]>fa[v][1] && wy[v][0]==1) wy[u][0]=1;
        if (fa[v][0]<fa[v][1] && wy[v][1]==1) wy[u][0]=1;
    }
    return 0;
}
int inte()
{
    memset(fa,0,sizeof(fa));
    memset(wy,0,sizeof(wy));
    mp.clear();
    for(int i=0;i<=n;i++)
        g[i].clear();
    return 0;
}
int main()
{
    freopen("in.txt","r",stdin);
    // freopen("out.txt","w",stdout);
    while(cin>>n && n)
    {
        inte();
        char s[105],a[105],b[105];
        int tot=1;
        cin>>s;
        mp[s]=1;
        for(int i=1;i<=n-1;i++)
        {
            cin>>a>>b;
            if(!mp[b]) mp[b]=++tot;
            if(!mp[a]) mp[a]=++tot;
            g[mp[b]].push_back(mp[a]);
        }
        dfs(1);
        if(fa[1][0]==fa[1][1]) printf("%d No\n",fa[1][1]);
        if(fa[1][0]>fa[1][1]) printf("%d %s",fa[1][0],wy[1][0]?"No\n":"Yes\n");
        if(fa[1][0]<fa[1][1]) printf("%d %s",fa[1][1],wy[1][1]?"No\n":"Yes\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值