As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely:
1. insert a key k to a empty tree, then the tree become a tree with
only one node;
2. insert a key k to a nonempty tree, if k is less than the root ,insert
it to the left sub-tree;else insert k to the right sub-tree.
We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape.
Input
There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n.
Output
One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic.
Sample Input
4 1 3 4 2
Sample Output
1 3 2 4
题意:
按照二叉搜索树的特征建树,最后输出相同的二叉搜索树、并且满足字典序最小
思路:
输出二叉树的前序即可
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int s[100010];
int l[100010];
int r[100010];
void print(int x)
{
if(x==-1)
return;
if(x!=1)
printf(" ");
printf("%d",s[x]);
print(l[x]);
print(r[x]);
}
int main()
{
int n;
while(~scanf("%d",&n))
{
memset(l,-1,sizeof(l));
memset(r,-1,sizeof(r));
for(int i=1;i<=n;i++)
scanf("%d",&s[i]);
for(int i=2;i<=n;i++)
{
int t=1;
while(1)
{
if(s[i]<s[t])
{
if(l[t]==-1)
{
l[t]=i;
break;
}
t=l[t];
}
else
{
if(r[t]==-1)
{
r[t]=i;
break;
}
t=r[t];
}
}
}
print(1);
printf("\n");
}
return 0;
}