How Many Tables
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 28936 Accepted Submission(s): 14359
Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5
Sample Output
2 4
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int t,n,m;
int per[1002];
int a[1002][2];
int vis[1002];
int find(int r){//并查集
if(per[r]==r) return r;
return per[r]=find(per[r]);
}
void join(int r1,int r2){//并查集
int f1=find(r1);
int f2=find(r2);
if(f1!=f2){
per[f1]=f2;
}
}
int main(){
scanf("%d",&t);
while(t--){
int ans=0;
memset(vis,0,sizeof(vis));
memset(per,0,sizeof(per));
memset(a,0,sizeof(a));
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++){
per[i]=i;//初始化,一个结点形成一棵树
}
for(int i=0;i<m;i++){
scanf("%d %d",&a[i][0],&a[i][1]);
join(a[i][0],a[i][1]);//合并
}
for(int i=1;i<=n;i++){
int j=find(i);
if(vis[j]==0){
vis[j]=1;
ans++;
}
}
printf("%d\n",ans);
}
return 0;
}