HDOJ A == B ?

A == B ?

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 68381    Accepted Submission(s): 10653



Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 

Input
each test case contains two numbers A and B.
 

Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 

Sample Input
  
  
1 2 2 2 3 3 4 3
 

Sample Output
  
  
NO YES YES NO
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
char str[1000000],s[1000000];
int main()
{
    int l,n,i,j,dot,a,b,c,d,sign,flag;
    while(scanf("%s %s",str,s)!=EOF){
        l=strlen(s);n=strlen(str);
        sign=flag=0;
        if(str[0]=='-')sign=1;
        if(s[0]=='-')flag=1;
        for(i=0;i<n;++i){
            if(str[i]=='-'&&i==0)continue;
            if(str[i]!='0')break;
        }
        for(j=0;j<l;++j){
            if(s[j]=='-'&&j==0)continue;
            if(s[j]!='0')break;
        }
        a=i;b=j;c=n-1;d=l-1;
        if(strchr(str,'.')){
            for(i=n-1;i>=0;--i){
                if(str[i]!='0'){
                    c=i;break;
                }
            }
        }if(str[c]=='.')c--;
        if(strchr(s,'.')){
            for(j=l-1;j>=0;--j)
                if(s[j]!='0'){
                    d=j;break;
                }
        }if(s[d]=='.')d--;
        if(a>b){
            for(i=b;i<=d;++i){
                if(str[i+a-b]!=s[i])break;
            }
            if((i-1)==d&&(i+a-b-1)==c&&sign==flag)printf("YES\n");
            else printf("NO\n");
        }
        else {
            for(j=a;j<=c;++j){
                if(str[j]!=s[j+b-a])break;
            }
            if((j-1)==c&&(j+b-a-1)==d&&sign==flag)printf("YES\n");
            else printf("NO\n");
        }
    }
    return 0;
}
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值