HDOJ5074Hatsune Miku【dp】

Hatsune Miku

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 894    Accepted Submission(s): 626


Problem Description
Hatsune Miku is a popular virtual singer. It is very popular in both Japan and China. Basically it is a computer software that allows you to compose a song on your own using the vocal package.

Today you want to compose a song, which is just a sequence of notes. There are only m different notes provided in the package. And you want to make a song with n notes.


Also, you know that there is a system to evaluate the beautifulness of a song. For each two consecutive notes a and b, if b comes after a, then the beautifulness for these two notes is evaluated as score(a, b).

So the total beautifulness for a song consisting of notes a 1, a 2, . . . , a n, is simply the sum of score(a i, a i+1) for 1 ≤ i ≤ n - 1.

Now, you find that at some positions, the notes have to be some specific ones, but at other positions you can decide what notes to use. You want to maximize your song’s beautifulness. What is the maximum beautifulness you can achieve?
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains two integers n(1 ≤ n ≤ 100) and m(1 ≤ m ≤ 50) as mentioned above. Then m lines follow, each of them consisting of m space-separated integers, the j-th integer in the i-th line for score(i, j)( 0 ≤ score(i, j) ≤ 100). The next line contains n integers, a 1, a 2, . . . , a n  (-1 ≤ a i  ≤ m, a i  ≠ 0), where positive integers stand for the notes you cannot change, while negative integers are what you can replace with arbitrary notes. The notes are named from 1 to m.
 

Output
For each test case, output the answer in one line.
 

Sample Input
  
  
2 5 3 83 86 77 15 93 35 86 92 49 3 3 3 1 2 10 5 36 11 68 67 29 82 30 62 23 67 35 29 2 22 58 69 67 93 56 11 42 29 73 21 19 -1 -1 5 -1 4 -1 -1 -1 4 -1
 

Sample Output
  
  
270 625
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5352  5351  5350  5349  5348 
 


题意:给-个m*m的矩阵M和n个数a1-an 1=<ai<=m;求M[ai][ai+1]的和=1<i<=m;

#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
int dp[110][55];//第i位的值为j时的最大值 
int num[110];
int map[55][55];
int MAX(int a,int b)
{
	return a>b?a:b;
}
int main()
{
	int t,n,m,k,i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		memset(dp,-1,sizeof(dp));//初始化所有位的数都确定 
		for(i=1;i<=m;++i)
		{
			for(j=1;j<=m;++j)
			{
				scanf("%d",&map[i][j]);
			}
			dp[1][i]=0;//假设第一位的值不确定 
		}
		for(i=1;i<=n;++i)
		{
			scanf("%d",&num[i]);
		}
		int max=-1;
		for(i=1;i<n;++i)
		{
			for(j=1;j<=m;++j)
			{
				if(num[i]>0&&num[i]!=j)//判断第i位的值是否确定若不确定则依次假设并循环判断dp[i+1][k]的最大值如果确定则将上一次循环假设不正确的k值所获得的dp[i+1][k]的值重新初始化                                
					dp[i][j]=-1;
				if(dp[i][j]==-1)continue;//如果第i位的值为确定j则进行下一次循环 
				for(k=1;k<=m;++k)
				{
					dp[i+1][k]=MAX(dp[i+1][k],dp[i][j]+map[j][k]);//第i为为j第i+1位的值为k时的最大值 
				}
			}
		}
		for(i=1;i<=m;++i)
		{
			max=MAX(max,dp[n][i]);	
		} 
		printf("%d\n",max);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值