HDOJ4336Card Collector【概率dp求期望+状态压缩】

Card Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3382    Accepted Submission(s): 1650
Special Judge


Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.  

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.
 

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks.  

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.
 

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.
 

Sample Input
  
  
1 0.1 2 0.1 0.4
 

Sample Output
  
  
10.000 10.500
 


 

题意:需要收集N张卡片给出集到每张卡片的概率求集出N张卡片的要取卡片次数的期望

#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
double dp[1<<20];//dp[i]表示状态为i时的期望; 
double p[22];
int main()
{
	int n,i,j,k;
	while(scanf("%d",&n)!=EOF){
		double p1=0;
		for(i=0;i<n;++i){
			scanf("%lf",&p[i]);
			p1+=p[i];
		}
		p1=1-p1;
		memset(dp,0,sizeof(dp));
		for(i=(1<<n)-2;i>=0;--i){
			double p2=0,e=1;
			for(j=0;j<n;++j){//列举当前状态所有情况; 
				if(i&1<<j){
					p2+=p[j];
				}
				else{
					e+=dp[i|(1<<j)]*p[j];
				}
			}
			dp[i]=e/(1-p1-p2);
		}
		printf("%.4lf\n",dp[0]);
	}
	return 0;
} 


 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值