hdojssworld VS DDD【概率dp求概率】

ssworld VS DDD

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1989    Accepted Submission(s): 383


Problem Description
One day, sssworld and DDD play games together, but there are some special rules in this games.
They both have their own HP. Each round they dice respectively and get the points P1 and P2 (1 <= P1, P2 <= 6). Small number who, whose HP to reduce 1, the same points will remain unchanged. If one of them becomes 0 HP, he loses.  
As a result of technical differences between the two, each person has different probability of throwing 1, 2, 3, 4, 5, 6. So we couldn’t predict who the final winner.  

 

Input
There are multiple test cases.
For each case, the first line are two integer HP1, HP2 (1 <= HP1, HP2 <= 2000), said the first player sssworld’s HP and the second player DDD’s HP.  
The next two lines each have six floating-point numbers per line. The jth number on the ith line means the the probability of the ith player gets point j. The input data ensures that the game always has an end.  
 

Output
One float with six digits after point, indicate the probability sssworld won the game.
 

Sample Input
  
  
5 5 1.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 1.000 5 5 0.000 0.000 0.000 0.000 0.000 1.000 1.000 0.000 0.000 0.000 0.000 0.000
 

Sample Output
  
  
0.000000 1.000000
 


题意:两人转骰子前人小于后人点数前人hp-1否则后人hp-1;问前人胜概率。

#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
double dp[1500][1500];//开到20000超内存 
double p[6][2];
int main()
{
	int hs,hd,i,j;
	while(scanf("%d%d",&hd,&hs)!=EOF){
		memset(dp,0,sizeof(dp));
		for(i=0;i<2;++i){
			for(j=0;j<6;++j){
				scanf("%lf",&p[j][i]);
			}
		}
		double p1=0,p2=0;
		for(i=1;i<6;++i){
			for(j=0;j<i;++j){
				p1=p1+p[i][0]*p[j][1];
				p2=p2+p[j][0]*p[i][1];
			}
		}
		if(p1==0){printf("%.6lf\n",0);continue;}
		double pr=p1+p2;
		p1=p1/pr;
		p2=p2/pr;
		dp[0][0]=1;
		for(i=0;i<hd;++i){
			for(j=0;j<hs;++j){
				if(i)
					dp[i][j]+=dp[i-1][j]*p1;
				if(j)
					dp[i][j]+=dp[i][j-1]*p2;
			}
		}
		pr=0;
		for(i=0;i<hs;++i)pr+=dp[hd-1][i]*p1;
		printf("%.6lf\n",pr);
	}
	return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值