hdoj3001Travelling【状压dp 类TSP】

8 篇文章 0 订阅
2 篇文章 0 订阅

 


Travelling

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5171    Accepted Submission(s): 1691


Problem Description
After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn't want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.
 

Input
There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.
 

Output
Output the minimum fee that he should pay,or -1 if he can't find such a route.
 

Sample Input
      
      
2 1 1 2 100 3 2 1 2 40 2 3 50 3 3 1 2 3 1 3 4 2 3 10
 

Sample Output
      
      
100 90 7
 

题意:类TSP问题每个点最多走两次

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#define inf 0x3f3f3f3f
using namespace std;
int MIN(int a,int b){
	return a<b?a:b;
}
int state[15];
int map[15][15];
int dp[60000][15]; 
int dig[60000][15];
void init(){
	state[1]=1;
	for(int i=2;i<12;++i){
		state[i]=state[i-1]*3;
	}
	for(int i=1;i<=state[11];++i){//将该状态变换为三进制; 
		int n=i,k=1;
		while(n){
			dig[i][k++]=n%3;
			n/=3;
		}
	}
}
int main()
{
	init();
	int i,j,k,n,m;
	while(scanf("%d%d",&n,&m)!=EOF){
		memset(dp,0x3f,sizeof(dp));
		memset(map,0x3f,sizeof(map));
		for(i=1;i<=m;++i){
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			if(map[a][b]>c){
				map[a][b]=map[b][a]=c;
			}
		}
		for(i=1;i<=n;++i)
			dp[state[i]][i]=0;//确定起点 
		int ans=inf;
		for(int s=state[1];s<state[n+1];++s){//枚举各种状态; 
			int flag=1;
			for(i=1;i<=n;++i){
				if(dig[s][i]==0)flag=0;//判断是否经过该点 
				if(dp[s][i]==inf)continue;
				for(j=1;j<=n;++j){
					if(i==j)continue;
					if(map[i][j]==inf||dig[s][j]==2)continue;//如若不能通行或经过该地超过两次 
					int news=s+state[j];//更新 
					dp[news][j]=MIN(dp[news][j],dp[s][i]+map[i][j]);
				}
			}
			if(flag){//如果该状态下所有点都经过过更新最小花费; 
				for(j=1;j<=n;++j){
					ans=MIN(ans,dp[s][j]);
				}
			}
		}
		if(ans==inf)
			printf("-1\n");
		else 
			printf("%d\n",ans);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值