HDOJ 题目3001Travelling(三进制状压DP,TSP)

Travelling

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5435    Accepted Submission(s): 1756


Problem Description
After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn't want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.
 

Input
There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.
 

Output
Output the minimum fee that he should pay,or -1 if he can't find such a route.
 

Sample Input
  
  
2 1 1 2 100 3 2 1 2 40 2 3 50 3 3 1 2 3 1 3 4 2 3 10
 

Sample Output
  
  
100 90 7
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   3004  3002  3006  3007  3008 
 题目大意:输入n,m,表示点数和边数,下边n行,建无向边。问把每个点都走一遍,每个点不能超过2次(可以走两次 大哭),起点,和终点随意,问最少走的距离
ac代码
153981592015-11-05 21:17:58Accepted3001327MS7288K1889 BC++XY_
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
#define INF 0x3f3f3f3f
using namespace std;
int mp[12][12];
int bit[11] = {1, 3, 9, 27, 81, 243, 729, 2187, 6561, 19683, 59049};
int dp[60000][12];
int num[60000][12];
void fun()//存下所有的数的3进制
{
    int i,j;
    for(i=0;i<bit[10];i++)
    {
        int temp=i;
        for(j=0;j<10;j++)
        {
            num[i][j]=temp%3;
            temp/=3;
        }
    }
}
int n,m;
int maxn;
void DP()
{
    int i,j,flag,k;
    memset(dp,INF,sizeof(dp));
    maxn=INF;
    for(i=0;i<n;i++)
        dp[bit[i]][i]=0;
    for(i=0;i<bit[n];i++)
    {
        flag=1;
        for(j=0;j<n;j++)
        {
            if(num[i][j]==0)
                flag=0;
            if(dp[i][j]==INF)
            {
                continue;
            }
            for(k=0;k<n;k++)
            {
                if(k==j||num[i][k]>=2||mp[j][k]==INF)
                {
                    continue;
                }
                int st=i+bit[k];
                dp[st][k]=min(dp[st][k],dp[i][j]+mp[j][k]);
            }
        }
        //printf("%d\n",flag);
        if(flag==1)
        {
            for(j=0;j<n;j++)
            {
               // printf("%d\n",dp[i][j]);
                maxn=min(maxn,dp[i][j]);
            }
        }
    }
}
int main()
{
    fun();
   // int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int i;
        memset(mp,INF,sizeof(mp));
        for(i=0;i<m;i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            a--;
            b--;
            if(c<mp[a][b])
                mp[a][b]=mp[b][a]=c;
        }
        //floyd();
        DP();
        if(maxn==INF)
            printf("-1\n");
        else
            printf("%d\n",maxn);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值