hdoj5533Dancing Stars on Me【判断正多边形凸包】

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 602    Accepted Submission(s): 321


Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

Input
The first line contains a integer  T  indicating the total number of test cases. Each test case begins with an integer  n , denoting the number of stars in the sky. Following  n  lines, each contains  2  integers  xi,yi , describe the coordinates of  n  stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
  
  
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

Sample Output
  
  
NO YES NO
 

Source
自己做了之后发现这题是让判正方形?
 
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#define eps 1e-8
using namespace std;
struct point{
	double x,y;
}A[110],result[110];
int sig(double n){
	if(fabs(n)<eps)return 0;
	else if(n<0)return -1;
	return 1;
}
double cp(point p1,point p2,point p3){
	return (p3.x-p1.x)*(p2.y-p1.y)-(p3.y-p1.y)*(p2.x-p1.x);
}
double dist(point a,point b){
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
bool cmp(point a,point  b){
	double ans=cp(A[0],a,b);
	if(sig(ans)==0){
		return dist(A[0],a)-dist(A[0],b)<=0;
	}
	else {
		return ans>0;
	}
}
int main()
{
	int t,i,j,k,n;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		int pos=0;
		for(i=0;i<n;++i){
			scanf("%lf%lf",&A[i].x,&A[i].y);
			if(A[pos].y>=A[i].y){
				if(A[pos].y==A[i].y){
					if(A[pos].x>A[pos].x)pos=i;
				}
				else pos=i;
			}
		}
		point temp;
		temp=A[0];A[0]=A[pos];A[pos]=temp;
		sort(A+1,A+n,cmp);
		int top=1;
		result[0]=A[0];
		result[1]=A[1];
		for(i=2;i<n;++i){
			while(cp(result[top-1],result[top],A[i])<0)top--;
			result[++top]=A[i];
		}
		if(top+1==n){
			double ans=dist(result[0],result[1]);
			for(i=0;i<=top;++i){
				if(sig(dist(result[i],result[(i+1)%n])-ans))break;
			}
			if(i<=top)printf("NO\n");
			else {
				printf("YES\n");
			}
		}
		else {
			printf("NO\n");
		}
	}
	return 0;	
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值