Language:
滑雪
Description
Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
1 2 3 4 5 16 17 18 19 6 15 24 25 20 7 14 23 22 21 8 13 12 11 10 9 一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。 Input
输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。
Output
输出最长区域的长度。
Sample Input 5 5 1 2 3 4 5 16 17 18 19 6 15 24 25 20 7 14 23 22 21 8 13 12 11 10 9 Sample Output 25 |
dfs
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
const int maxn=110;
int n,m,ans;
struct Node{
int x,y;
int num;
}A[maxn*maxn];
int map[maxn][maxn];
int dist[maxn][maxn];
int mov[][2]={0,1,0,-1,1,0,-1,0};
bool cmp(Node a,Node b){
return a.num<b.num;
}
bool judge(int x,int y){
return x>=0&&x<n&&y>=0&&y<m;
}
void dfs(int x,int y){
ans=max(ans,dist[x][y]);
for(int i=0;i<4;++i){
int xx=x+mov[i][0];
int yy=y+mov[i][1];
if(judge(xx,yy)&&map[xx][yy]<map[x][y]&&(dist[x][y]+1>dist[xx][yy])){
dist[xx][yy]=dist[x][y]+1;
dfs(xx,yy);
}
}
}
int main()
{
int i,j,k,num=0;
scanf("%d%d",&n,&m);
for(i=0;i<n;++i){
for(j=0;j<m;++j){
scanf("%d",&map[i][j]);
A[num].x=i;A[num].y=j;A[num].num=map[i][j];
num++;
}
}ans=1;
sort(A,A+num,cmp);
memset(dist,0,sizeof(dist));
for(i=num-1;i>=0;--i){
if(dist[A[i].x][A[i].y]==0){
dist[A[i].x][A[i].y]=1;
dfs(A[i].x,A[i].y);
}
if(ans>i)break;
}
printf("%d\n",ans);
return 0;
}
记忆化搜索
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
const int maxn=110;
int n,m;
int map[maxn][maxn];
int dp[maxn][maxn];
int vis[maxn][maxn];
int mov[][2]={0,1,0,-1,1,0,-1,0};
bool judge(int x,int y){
return x>=0&&x<n&&y>=0&&y<m;
}
int dfs(int x,int y){
if(dp[x][y])return dp[x][y];
dp[x][y]=1;
for(int i=0;i<4;++i){
int xx=x+mov[i][0];
int yy=y+mov[i][1];
if(judge(xx,yy)&&map[xx][yy]<map[x][y]){
dp[x][y]=max(dfs(xx,yy)+1,dp[x][y]);
}
}
return dp[x][y];
}
int main()
{
int i,j,k;
scanf("%d%d",&n,&m);
for(i=0;i<n;++i){
for(j=0;j<m;++j){
scanf("%d",&map[i][j]);
}
}
memset(dp,0,sizeof(dp));
int ans=1;
for(i=0;i<n;++i){
for(j=0;j<m;++j){
if(!dp[i][j]){
dp[i][j]=dfs(i,j);
}
ans=max(ans,dp[i][j]);
}
}
printf("%d\n",ans);
return 0;
}