hdoj5187zhx's contest【快速幂+快速乘法】

105 篇文章 0 订阅

zhx's contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1835    Accepted Submission(s): 577


Problem Description
As one of the most powerful brushes, zhx is required to give his juniors  n  problems.
zhx thinks the  ith  problem's difficulty is  i . He wants to arrange these problems in a beautiful way.
zhx defines a sequence  {ai}  beautiful if there is an  i  that matches two rules below:
1:  a1..ai  are monotone decreasing or monotone increasing.
2:  ai..an  are monotone decreasing or monotone increasing.
He wants you to tell him that how many permutations of problems are there if the sequence of the problems' difficulty is beautiful.
zhx knows that the answer may be very huge, and you only need to tell him the answer module  p .
 

Input
Multiply test cases(less than  1000 ). Seek  EOF  as the end of the file.
For each case, there are two integers  n  and  p  separated by a space in a line. ( 1n,p1018 )
 

Output
For each test case, output a single line indicating the answer.
 

Sample Input
  
  
2 233 3 5
 

Sample Output
  
  
2 1
Hint
In the first case, both sequence {1, 2} and {2, 1} are legal. In the second case, sequence {1, 2, 3}, {1, 3, 2}, {2, 1, 3}, {2, 3, 1}, {3, 1, 2}, {3, 2, 1} are legal, so the answer is 6 mod 5 = 1
 

Source
 

如果n=1n=1n=1,答案是111,否则答案是2n−22^n-22n2

证明:aia_iai肯定是最小的或者最大的。考虑另外的数,如果它们的位置定了的话,那么整个序列是唯一的。 那么aia_iai是最小或者最大分别有2n−12^{n-1}2n1种情况,而整个序列单调增或者单调减的情况被算了2次,所以要减2。

要注意的一点是因为p>231p>2^{31}p>231,所以要用快速乘法。用法与快速幂相同。如果直接乘会超过long long范围,从而wa掉。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<vector>
#include<list>
using namespace std;
unsigned long long multi(unsigned long long a, unsigned long long b,unsigned long long c) {
	unsigned long long ans = 0;
	while (b) {
		if (b & 1) {
			ans += a;ans %= c;
		}
		a += a;a %= c;
		b >>= 1;
	}
	return ans;
}
unsigned long long Pow(unsigned long long a, unsigned long long b, unsigned long long c) {
	long long ans = 1;
	while (b) {
		if (b & 1) {
			ans = multi(ans, a, c);
		}
		a = multi(a, a, c);
		b >>= 1;
	}
	return ans;
}
int main()
{
	unsigned long long n, m;
	while (scanf("%llu%llu", &n, &m) != EOF)
	{
		if (n == 1) {
			printf("%llu\n",1%m);
		}
		else {
			printf("%llu\n", (Pow(2, n, m) - 2 + m) % m);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值