hdoj5319Painter

Painter

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1833    Accepted Submission(s): 739


Problem Description
Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several square grids. He drew diagonally, so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a grid is drew by both red and blue, it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state.
 

Input
The first line is an integer T describe the number of test cases.
Each test case begins with an integer number n describe the number of rows of the drawing board.
Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn.
1<=n<=50
The number of column of the rectangle is also less than 50.
Output
Output an integer as described in the problem description.
 

Output
Output an integer as described in the problem description.
 

Sample Input
  
  
2 4 RR.B .RG. .BRR B..R 4 RRBB RGGB BGGR BBRR
 

Sample Output
  
  
3 6
 

Author
ZSTU
 

Source

题意:给出一个矩形每次可以从中选出一个矩形可以将其正对角线涂成R负对角线涂成B当一个格子同时被涂上R和B后该格子颜色变为G同一个格子只能图一种颜色依次问最少需要多少次可以所得所给矩形。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
#include<map>
#include<vector>
#include<stack>
using namespace std;
typedef long long LL;
const int maxn=55;
int used[maxn][maxn];
int vis[maxn][maxn];
char Map[maxn][maxn];
int n,m;
void drew1(int x,int y){
    int k=0;
    while(true){
        if(x+k>n||y+k>m)break;
        if(Map[x+k][y+k]=='R'||Map[x+k][y+k]=='G'){
            if(used[x+k][y+k]==1)break;
            used[x+k][y+k]=1;
            vis[x+k][y+k]++;k++;
        }
        else break;
    }k=1;
    while(true){
        if(x-k<1||y-k<1)break;
        if(Map[x-k][y-k]=='R'||Map[x-k][y-k]=='G'){
            if(used[x-k][y-k]==1)break;
            used[x-k][y-k]=1;
            vis[x-k][y-k]++;k++;
        }
        else break;
    }
}
void drew2(int x,int y){
    int k=0;
    while(true){
        if(x-k<1||y+k>m)break;
        if(Map[x-k][y+k]=='B'||Map[x-k][y+k]=='G'){
            if(used[x-k][y+k]==0)break ;
            used[x-k][y+k]=0;
            vis[x-k][y+k]++;k++;
        }
        else break;
    }k=1;
    while(true){
        if(x+k>n||y-k<1)break;
        if(Map[x+k][y-k]=='B'||Map[x+k][y-k]=='G'){
            if(used[x+k][y-k]==0)break;
            used[x+k][y-k]=0;
            vis[x+k][y-k]++;k++;
        }
        else break;
    }
}
void drew3(int x,int y){
    int k=0;
    if(used[x][y]==0)return ;
    while(true){
        if(x-k<1||y+k>m)break;
        if(Map[x-k][y+k]=='G'&&vis[x-k][y+k]!=2){
            if(vis[x-k][y+k]==1){
                if(used[x-k][y+k]!=0){
                    vis[x-k][y+k]++;
                    used[x-k][y+k]=0;
                }
                else break;
            }
            else {
                vis[x-k][y+k]++;
                used[x-k][y+k]=0;
            }
            k++;
        }
        else break;
    }k=1;
    while(true){
        if(x+k>n||y-k<1)break;
        if(Map[x+k][y-k]=='G'&&vis[x+k][y-k]!=2){
            if(vis[x+k][y-k]==1){
                if(used[x+k][y-k]!=0){
                    used[x+k][y-k]=0;
                    vis[x+k][y-k]++;
                }
                else break;
            }
            else {
                used[x+k][y-k]=0;
                vis[x+k][y-k]++;
            }
            k++;
        }
        else break;
    }
}
void drew4(int x,int y){
    int k=0;
    if(used[x][y]==1)return ;
    while(true){
        if(x+k>n||y+k>m)break;
        if(Map[x+k][y+k]=='G'&&vis[x+k][y+k]!=2){
            if(vis[x+k][y+k]==1){
                if(used[x+k][y+k]!=1){
                    used[x+k][y+k]=1;
                    vis[x+k][y+k]++;
                }
                else break;
            }
            else {
                used[x+k][y+k]=1;
                vis[x+k][y+k]++;
            }
            k++;
        }
        else break;
    }k=1;
    while(true){
        if(x-k<1||y-k<1)break;
        if(Map[x-k][y-k]=='G'&&vis[x-k][y-k]!=2){
            if(vis[x-k][y-k]==1){
                if(used[x-k][y-k]!=1){
                    used[x-k][y-k]=1;
                    vis[x-k][y-k]++;
                }
                else break;
            }
            else {
                used[x-k][y-k]=1;
                vis[x-k][y-k]++;
            }
            k++;
        }
        else break;
    }
}
int main()
{
    int t;cin>>t;
    while(t--){
        scanf("%d",&n);
        for(int i=1;i<=n;++i){
            scanf("%s",Map[i]+1);
        }
        m=strlen(Map[1]+1);
        int ans=0;
        memset(used,-1,sizeof(used));
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;++i){
            for(int j=1;j<=m;++j){
                if(Map[i][j]!='.'){
                    if(Map[i][j]=='R'&&!vis[i][j]){
                        drew1(i,j);ans++;
                    }
                    else if(Map[i][j]=='B'&&!vis[i][j]){
                        drew2(i,j);ans++;
                    }

                }
            }
        }
        for(int i=1;i<=n;++i){
            for(int j=1;j<=m;++j){
                if(Map[i][j]=='G'&&vis[i][j]!=2){
                    ans=ans+(vis[i][j]==1?1:2);
                    drew3(i,j);drew4(i,j);
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值