RGCDQ
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 2711 Accepted Submission(s): 1070
Problem Description
Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know
maxGCD(F(i),F(j))
(L≤i<j≤R)
Input
There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.
In the next T lines, each line contains L, R which is mentioned above.
All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000
In the next T lines, each line contains L, R which is mentioned above.
All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000
Output
For each query,output the answer in a single line.
See the sample for more details.
See the sample for more details.
Sample Input
2 2 3 3 5
Sample Output
1 1
Author
ZSTU
Source
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
#include<map>
#include<stack>
using namespace std;
const int maxn=1000010;
int f[maxn];
int pre[maxn][10];
bool vis[maxn],used[10];
int gcd(int a,int b){
return b==0?a:gcd(b,a%b);
}
void dabiao(){
for(int i=2;i<maxn;++i){
if(vis[i])continue;vis[i]=true;
for(int j=i;j<maxn;j+=i){
f[j]++;vis[j]=true;
}
}
for(int i=2;i<maxn;++i){
for(int j=1;j<=7;++j){
if(f[i]==j){
pre[i][j]=pre[i-1][j]+1;
}
else {
pre[i][j]=pre[i-1][j];
}
}
}
}
int main()
{
dabiao();
int t;cin>>t;
while(t--){
int l,r;
scanf("%d%d",&l,&r);
int ans=0;
memset(used,false,sizeof(used));
for(int i=1;i<=7;++i){
int cnt=pre[r][i]-pre[l-1][i];
if(cnt>1){
used[i]=true;
ans=max(ans,i);
}
else if(cnt==1){
used[i]=true;
}
}
for(int i=1;i<=7;++i){
for(int j=i+1;j<=7;++j){
if(used[i]&&used[j]){
ans=max(ans,gcd(i,j));
}
}
}
printf("%d\n",ans);
}
return 0;
}