hdoj5631Rikka with Graph【并查集】

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1037    Accepted Submission(s): 497


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number  T(T30) ——The number of the testcases.

For each testcase, the first line contains a number  n(n100) .

Then n+1 lines follow. Each line contains two numbers  u,v  , which means there is an edge between u and v.
 

Output
For each testcase, print a single number.
 

Sample Input
  
  
1 3 1 2 2 3 3 1 1 3
 

Sample Output
  
  
9
 

Source
 

/* ***********************************************
Author       : ryc
Created Time : 2016-08-01 Monday
File Name    : E:\acmcode\hdoj\5631.cpp
LANGUAGE     : c++
Copyright 2016 ryc All Rights Reserved
************************************************ */
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
#include<vector>
using namespace std;
const int maxn =210;
int n,father[maxn];
struct Node{
    int u,v;
}A[maxn];
int Find(int x){
    return x==father[x]?x:father[x]=Find(father[x]);
}
bool judge(int a,int b){
    for(int i=1;i<=n;++i){
        father[i]=i;
    }
    for(int i=1;i<=n+1;++i){
        if(i==a||i==b)continue;
        int aa=Find(A[i].u);
        int bb=Find(A[i].v);
        father[aa]=bb;
    }
    int root=Find(1);
    for(int i=1;i<=n;++i){
        if(Find(i)!=root)return false;
    }
    return true;
}
int main()
{
    int t;cin>>t;
    while(t--){
        scanf("%d",&n);
        for(int i=1;i<=n+1;++i){
            scanf("%d%d",&A[i].u,&A[i].v);
        }
        int ans=0;
        for(int i=1;i<=n+1;++i){
            for(int j=i;j<=n+1;++j){
                if(judge(i,j))ans++;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值