PAT 1025 PAT Ranking (25 分)

原题链接:1025 PAT Ranking (25 分)
关键词:排序

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously(同时地) in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题目大意:

pat考试的时候,每个人都有一个考场并有自己的成绩,现在要根据所有人的成绩,输出每个人在考场内的排名以及总排名。

思路:

  • 用结构体存储每个考生的id、考场号、成绩、地区排名和总排名。排序通过实现cmp函数,用sort来完成。
  • 读入数据的过程中确定每个考生的考场号,然后读完一个考场对该考场内的人进行排序,确认每个人的考场内排名。
  • 最后再对全体进行排序,得到总排名。

排序的逻辑:

分数按从大到小排序,分数相同时按照考生号字典序非递减排序:

bool cmp(Student a, Student b){
    if(a.score != b.score) return a.score  > b.score;
    else return strcmp(a.id, b.id) < 0;
}

分数相同的人共用一个名次:

//排序之后,第一名排名定位1
if(当前人成绩 == 上一个人成绩)
	当前人排名 = 上一个人排名
else
	当前人排名 = 在他之前的所有人数量 + 1 

代码实现:

#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

struct Student{
    char id[13];
    int score;
    int local_id;
    int local_rank;
    int final_rank;
    
}stu[30010];

bool cmp(Student a, Student b){
    if(a.score != b.score) return a.score  > b.score;
    else return strcmp(a.id, b.id) < 0;
}

int n, k; //n地区数 k地区内人数 num学生总人数

int main(){
    int num = 0;
    
    cin >> n;
    for(int i = 1; i <= n; i ++ ){
        cin >> k;
        for(int j = 1; j <= k; j ++ ){
            cin >> stu[num].id >> stu[num].score;
            stu[num].local_id = i;
            num++;
        }
        
        sort(stu + num - k, stu + num, cmp);    //地区内排序
        stu[num - k].local_rank = 1;
        for(int j = num - k + 1; j < num; j ++ ){
            if(stu[j].score == stu[j - 1].score)
                stu[j].local_rank = stu[j - 1].local_rank;
            else
                stu[j].local_rank = j + 1 - (num - k);
        }
    }
    sort(stu, stu + num, cmp);  //全体排序
    stu[0].final_rank = 1;
    for(int j = 1; j < num; j ++ ){
        if(stu[j].score == stu[j - 1].score)
            stu[j].final_rank = stu[j - 1].final_rank;
        else
            stu[j].final_rank = j + 1;
    }
    
    cout << num << endl;
    for(int i = 0; i < num; i ++ ){
        cout << stu[i].id << " " << stu[i].final_rank << " " << stu[i].local_id << " " << stu[i].local_rank << endl;
    }
    
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值