Catch That Cow--poj3278

Time Limit: 2000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

输入

Line 1: Two space-separated integers: N and K

输出

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

示例输入

5 17

示例输出

4
 
 
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int k[]={1,-1};
struct node
{
    int x;
    int step;
}ls[1000000];
int bj[1000000];
void bfs(int n, int m)
{
    struct node f, t;
    int tp = 0, tl = 0, i;
    t.x = n;
    t.step = 0;
    ls[tl++] = t;
    bj[n] = 1;
    while(tp < tl)
    {
        t = ls[tp++];
        if(t.x == m)
           printf("%d\n",t.step);
        for(i = 0; i < 3; i++)
        {
            if(i == 2)
              f.x = t.x*2;
            else
            f.x=t.x+k[i];
            if(!bj[f.x] && f.x > 0 && f.x < 2*m)
            {
                bj[f.x] = 1;
                f.step = t.step + 1;
                ls[tl++] = f;
            }
        }
    }
}
int main()
{
    int n, m;
    while(~scanf("%d%d",&n,&m))
    {
        if(n >= m)
        {
            printf("%d\n",n-m);
            continue;
        }
        bfs(n,m);
    }
    return 0;
}


提示

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值