POJ 3278 Catch That Cow(DFS)

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题解:分情况,设f(n,t) 是 n 到 t 的最短时间。
1.如果n>k,直接输出n-k;

2.如果n=0,那么走n-1和走2*n都是无意义的,只能走n+1,此时n先走到1,故f(0,k)=(1,k)+1,且令n=1往下操作;

3.如果k是偶数 ,a情况:如果k/2>n,f(n,k) = f(n,k/2)+1;
                           b情况:如果k/2<n,f(n,k) = min( f(n,k/2)+1,k-n(直接一步步过去) );

4.如果k是奇数,那么必定是f(n,k) = min(f(n,k+1),f(n,k-1))+1;

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int  n,m;
int dfs(int cur,int target)
{

    if(cur>=target)
        return cur-target;
    if(target%2==0)
    {
        if(cur<target/2)
            return dfs(cur,target/2)+1;
        else if(cur==target/2)
            return 1;
        else
            return min(1+cur-target/2,target-cur);
    }
    else
    {
        return min(dfs(cur,target+1),dfs(cur,target-1))+1;
    }
}
int main()
{
    int flag=0;
    scanf("%d %d",&n,&m);
    if(n==0)
        flag=1;
    printf("%d\n",dfs(n+flag,m)+flag);
    return 0;
}



  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值