In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1–300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1–N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.
Output
For every case:
Output R, represents the number of incorrect request.
Sample Input
10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100
Sample Output
2
题意是 体育馆的座位坐人 一圈是300 x,y隔了z米,然后求出这m个关系之间有多少个错误,所谓错误就是当前这个关系与之前的有冲突。
做法就是 将fx,fy都赋给一个相对于根的num权值,每次拿num值比较是否冲突即可
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int pre[50002],num[50005];
int ans,mod=300;
int find(int x)
{
if(x!=pre[x])
{
int fx=pre[x];
pre[x]=find(fx);
num[x]=(num[x]+num[fx])%mod;
}
return pre[x];
}
void join(int x,int y,int z)
{
int fx=find(x);
int fy=find(y);
if(fx!=fy)
{
pre[fy]=fx;
num[fy]=(num[x]-num[y]+mod+z)%mod;
}
else
{
if(num[y]!=(num[x]+z)%mod)
ans++;
}
}
int main()
{
int n,m,i;
while(~scanf("%d%d",&n,&m))
{
int x,z,y;
ans=0;
for(i=1;i<=n;i++)
{
pre[i]=i;
num[i]=0;
}
while(m--)
{
scanf("%d%d%d",&x,&y,&z);
join(x,y,z);
}
printf("%d\n",ans);
}
return 0;
}