Leading and Trailing LightOJ - 1282

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output
For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input
5
123456 1
123456 2
2 31
2 32
29 8751919
Sample Output
Case 1: 123 456
Case 2: 152 936
Case 3: 214 648
Case 4: 429 296
Case 5: 665 669
题意是求n的k次方前三位和后三位
后3位快速幂
前3位:c=klog10(n)-(int)(klog10(n));
c=pow(10,c);
设10p=nk,。10p=10y*10x(科学计数法),所以log10(n)=x+y,我们设x为(int)log10(n).这样10x就是科学计数法后面的10几次方,10y就是前面的小数部分

#include<stdio.h>
#include<string.h>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long ll;
int mod=1000;
long long rpow(ll n,ll p)
{
    long long ans=1;
    while(p)
    {
        if(p%2)
            ans=ans*n%mod;
        n=n*n%mod;
        p/=2;
    }
    return ans%mod;
}
int main()
{
    int t,q=1;
    scanf("%d",&t);
    while(t--)
    {
        ll n,k;
        scanf("%lld%lld",&n,&k);
        double c=k*log10(n)-(int)(k*log10(n));
        ll b=rpow(n,k);
        c=pow(10,c);
        ll a=c*100;
        printf("Case %d: %lld %03lld\n",q++,a,b);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值