1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991
#include<stdio.h>
int main(){
	int a , b ,sum , i = 0 ,count = 0 , j;
	char ret[10] , tmp;
	scanf("%d %d",&a,&b);
	sum = a + b;
    if(sum == 0){
        printf("0");
        return 0;
    }
	if(sum < 0){
		sum = -sum;
		while(sum > 0){
			if(count == 3){
				count = 0;
				ret[i++] = ',';
				continue;
			}
			ret[i++] = (sum % 10) + '0';
			sum /= 10;
			count ++;
		}
		for(j = 0;j < i / 2;j ++){
			tmp = ret[j];
			ret[j] = ret[i - j - 1];
			ret[i - j - 1] = tmp;
		}
		for(j = i - 1;j >= 0;j --){
			ret[j + 1] = ret[j];
		}
		ret[0] = '-';
        ret[i + 1] = '\0';
        printf("%s",ret);
	}else{
		while(sum > 0){
			if(count == 3){
				count = 0;
				ret[i++] = ',';
				continue;
			}
			ret[i++] = (sum % 10) + '0';
			sum /= 10;
			count ++;
		}
		for(j = 0;j < i / 2;j ++){
			tmp = ret[j];
			ret[j] = ret[i - j - 1];
			ret[i - j - 1] = tmp;
		}
        ret[i] = '\0';
        printf("%s",ret);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

R_1220

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值