PAT菜鸡进化史_乙级_1052
萌萌哒表情符号通常由“手”、“眼”、“口”三个主要部分组成。简单起见,我们假设一个表情符号是按下列格式输出的:
[左手]([左眼][口][右眼])[右手]
现给出可选用的符号集合,请你按用户的要求输出表情。
输入格式:
输入首先在前三行顺序对应给出手、眼、口的可选符号集。每个符号括在一对方括号 []
内。题目保证每个集合都至少有一个符号,并不超过 10 个符号;每个符号包含 1 到 4 个非空字符。
之后一行给出一个正整数 K,为用户请求的个数。随后 K 行,每行给出一个用户的符号选择,顺序为左手、左眼、口、右眼、右手——这里只给出符号在相应集合中的序号(从 1 开始),数字间以空格分隔。
输出格式:
对每个用户请求,在一行中输出生成的表情。若用户选择的序号不存在,则输出 Are you kidding me? @\/@
。
输入样例:
[╮][╭][o][~\][/~] [<][>]
[╯][╰][^][-][=][>][<][@][⊙]
[Д][▽][_][ε][^] ...
4
1 1 2 2 2
6 8 1 5 5
3 3 4 3 3
2 10 3 9 3
输出样例:
╮(╯▽╰)╭
<(@Д=)/~
o(^ε^)o
Are you kidding me? @\/@
思路:
这里不能用char!!!一开始用了char全线崩盘orz…
其他就注意一下"Are you kidding me"这里记得反斜杠想要输出的话前面得再加个反斜杠
Code:
#include <iostream>
#include <string>
#include <vector>
int main(){
using namespace std;
// store the emoji part
string str;
vector<string> emoji[3];
for (int i = 0; i < 3; i++){
getline(cin, str);
unsigned int a = 0, b = 1;
while (a < str.size() && b < str.size()){
if (str[a] == '[' && str[b] == ']'){
emoji[i].push_back(str.substr(a + 1, b - a - 1));
a = b + 1;
b = b + 2;
}else if (str[a] == '['){
b++;
}else{
a++;
b++;
}
}
}
// input the emoji wanted
int hand_num = emoji[0].size(), eye_num = emoji[1].size(), mouth_num = emoji[2].size();
int n;
cin >> n;
vector<string> output(n);
int lhand, leye, mouth, reye, rhand;
for (int i = 0; i < n; i++){
cin >> lhand >> leye >> mouth >> reye >> rhand;
if (lhand > hand_num || rhand > hand_num || leye > eye_num || reye > eye_num || mouth > mouth_num || lhand < 1 || leye < 1 || mouth < 1 || reye < 1 || rhand < 1)
output[i] = "Are you kidding me? @\\/@";
else
output[i] = emoji[0][lhand - 1] + '(' + emoji[1][leye - 1] + emoji[2][mouth - 1] + emoji[1][reye - 1] + ')' + emoji[0][rhand - 1];
}
// display the emoji
for (int i = 0; i < n; i++)
cout << output[i] << endl;
return 0;
}