HDU1009 FatMouse' Trade

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 57164    Accepted Submission(s): 19152


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
  
  
13.333 31.500
 

题目大意:一只肥鼠准备了M磅的猫食物,仓库里面有肥鼠最喜欢吃的JavaBean(一种豆子的名称吧),这个仓库有N个房间,每个房间里面有 J[i] 磅JavaBean,但是每个房间都有猫在看管,想要得到它最喜欢吃的JavaBean就需要F[i]磅的猫食作为交换得到相应JavaBean;它也可以不完全换取到这个房间的所有JavaBean,肥鼠可以用 J[i]* a%换取相应F[i]* a%的JavaBean;那么问你老鼠要怎样才可以用仅有的猫食物换取到最多的JavaBean;


输入第一行包含两个整数 M,N分别代表老鼠准备的猫食和仓库有共有多少间房间;接下来有N行,每一行有两个整数J[i]和F[i]分别表示换取J[i]磅的JavaBean需要花费F[i]磅的猫食才可以交换,输入两个-1表示结束;并且所有的整数不超过1000;


输出相应的猫食可以换取到最多的JavaBean


省题:依题意可知,有仅有的食物换取最多的食物,只要保证每次花费最少换取到最多就能得到最大值。改题是求解最大值,同时每次都是考虑到局部最优,所以可以选择用贪心算法去解决该类问题;


思路:定义一个double型数组 存放每个房间可以获利的最大比例   mid[i]=j[i]*1.0/f[i]; 然后对mid进行降序排序,将最大的最先考虑,这样就保证了我们每次换取猫食是最多的;然后求和就好了;


给出代码如下:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
int m, n;
int J[1005], f[1005];
double sum=0,mid[1005];
while (scanf("%d%d",&m,&n),m!=-1&&n!=-1)
{
sum = 0.0;
for (int i = 0; i < n; i++)
{
scanf("%d%d", &J[i], &f[i]);
mid[i] = J[i] * 1.0 / f[i];
}
for (int i = 0; i < n-1; i++)
{
int t;
double Max = mid[i];
for (int j = i+1; j < n; j++)
{
if (Max < mid[j]){ Max = mid[j]; t = j; }
}
if (Max!=mid[i]) 
{
int k = J[i];
J[i] = J[t];
J[t] = k;
k = f[i];
f[i] = f[t];
f[t] = k;
double s;
s = mid[i];
mid[i] = mid[t];
mid[t] = s;
}
}
/*因为数据量不是很大,直接用选择排序法对mid进行排序,同时对mid数组对应的j[i]和f[i]数组进行相应的交换*/
for (int i = 0; i < n&&m!=0; i++)
{
if (f[i]>m)
{
sum = sum + m / (f[i]*1.0 )* J[i]; 
m = 0;
}
else if(f[i]<=m)
{
sum = sum + J[i]; m = m - f[i];
}
}
/*把每次求得的最优解相加得到最终的最优解*/
printf("%.3lf\n", sum);
}
return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值