【贪心】 hdu1009 FatMouse' Trade

6 篇文章 0 订阅

FatMouse' Trade

http://acm.hdu.edu.cn/showproblem.php?pid=1009

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
  
  
13.333 31.500


简单贪心,计算f[i]/j[i]的比例,优先满足比例大的。

#include<cstdio>
#include<algorithm>
using namespace std;
#define MAX 1001
struct node
{
    double j,f,c;
}num[MAX];
int n;
double m;
bool cmp(const struct node &a,const struct node &b)
{
    return b.c>a.c;
}
int main()
{
    for(;scanf("%lf%d",&m,&n);)
    {
        if(m==-1&&n==-1) break;
        for(int i=0;i<n;++i)
        {
            scanf("%lf%lf",&num[i].j,&num[i].f);
            num[i].c=num[i].f/num[i].j;
        }
        sort(num,num+n,cmp);
        double summ=0.0;
        for(int i=0;i<n;++i)
        {
            if(m<=0) break;
            if(m>=num[i].f)
            {
                summ+=num[i].j;
                m-=num[i].f;
            }
            else
            {
                summ+=(num[i].j*(m/num[i].f));
                m=0;
            }
        }
        printf("%.3f\n",summ);
    }
    return 0;
}
来源: http://blog.csdn.net/acm_ted/article/details/7771103

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值