B - Climbing Worm
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.
Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
Sample Input
10 2 1
20 3 1
0 0 0
Sample Output
17
19
#include<stdio.h>
#define M 1000008
int main()
{
int s,a,b;
while(scanf("%d%d%d",&s,&a,&b)!=EOF)
{
if(s==0&&a==0&&b==0)
break;
int i,t=0,p=0;
for(i=0;i<M;i++)
{
p=p+a;
t++;
if(p>=s)
break;
p=p-b;
t++;
}
printf("%d\n",t);
}
return 0;
}
百度翻译:
一英寸的蠕虫在一个好几英寸深的底部。它有足够的能量来爬u英寸每分钟,但然后休息一分钟,然后再攀登。在休息期间,它滑下来D英寸。攀爬和休息的过程然后重复。多久虫爬出井?我们总是把一分钟的一分钟算为一分钟,如果蠕虫在爬完的时候到达了井的顶部,我们就假定蠕虫会出来。
输入
将有多个问题实例。每行将包含3个正整数n,u和d。这些给出了上文所述的值。此外,您还可以假设D <和N < 100。n = 0的值表示输出端。
输出
每个输入实例应该在一行中生成一个整数,表示蠕虫爬出井所需的分钟数。
样本输入
10 2 1
20 3 1
0 0 0
示例输出
十七
十九