第二周 HDU 1049

An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We’ll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we’ll assume the worm makes it out.
Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
Sample Input
10 2 1
20 3 1
0 0 0
Sample Output
17
19

问题简述:输入井高度n,一分钟往上爬u,然后必须休息一分钟并向下滑d,输出几分钟后爬出井口。
问题分析:如果在往上爬的过程中爬出井口,则不再计算下滑过程。所以要在结束时判断好。
程序说明:for循环计算了最后一次之前的循环的分钟数,然后当累计的路程a加上向上路程u大于n时,下一次将爬出井口。输出累计分钟数i加最后向上的一分钟。

#include <iostream>
using namespace std;

int main()
{
	int n, u, d;
	while (cin >> n >> u >> d)
	{
		int i = 0; if (n == 0)break;
		for(int a=0; a + u < n;i+=2)
	
			a = a + u - d;
			
		
		 cout << i+1 << endl;

	}

	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值