poj1064 二分答案

题目:

Cable master
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 59025 Accepted: 12296

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00


题意:

n条绳子,长度分别为li,如果从他们中切割出k条长度相同的绳子,问每条最长能有多长?


思路:

    这道题答案具有连续性,即某一值满足条件时,比这个值小的值也同样满足条件。所有我们二分答案,找到恰好满足条件的最大长度即可。每次二分后,判断当前中点的长度是否满足题设条件,若满足,则最长的长度一定在[mid,r]中,否则在[l,mid]中。

    这道题的坑点主要有两个,一个是二分次数的确定,这个东西千万不要用eps(设置不当会出现奇怪的问题)。。二分100次就好。。ps:我就是饿死,从外面跳下去,也绝对不会在二分里用eps了!

    还有就是%.2lf  !!double的进位,为了防止四舍五入(ps:规则是小位上的数大于五就进1,比如0.155输出0.15 ; 0.151输出0.16 ; 0.1501输出0.16),我们要(floor)(ans*100)/100 这样来完整的留下小数点后两位。

代码:二分

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<stack>
#include<set>
#define sd(x) scanf("%d",&x)
#define ss(x) scanf("%s",x)
#define sc(x) scanf("%c",&x)
#define sf(x) scanf("%f",&x)
#define slf(x) scanf("%lf",&x)
#define slld(x) scanf("%lld",&x)
#define me(x,b) memset(x,b,sizeof(x))
#define pd(d) printf("%d\n",d);
#define plld(d) printf("%lld\n",d);
#define eps 1.0E-8
// #define Reast1nPeace

typedef long long ll;

using namespace std;

const int INF = 0x3f3f3f3f;
int n,k;

double a[10010];

bool judge(double len){
	int sum = 0;
	for(int i = 0 ; i<n ; i++){
		sum += (int)(a[i]/len);
	}
	if(sum>=k)	return 1;
	return 0;
}

int main(){
#ifdef Reast1nPeace
	freopen("in.txt", "r", stdin);
	freopen("out.txt", "w", stdout);
#endif
	ios::sync_with_stdio(false);
	cin>>n>>k;
	double l = 0,r = 0;
	for(int i = 0 ; i<n ; i++){
		cin>>a[i];
		if(r < a[i]){
			r = a[i];
		}
	}
	for(int i = 0 ; i<100 ; i++){
		double mid = (l+r)/2;
		if(judge(mid)){
			l = mid;
		}
		else{
			r = mid;
		}
	}
	printf("%.2lf\n",(floor)(l*100)/100);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值