【BZOJ 3239】 Discrete Logging

3239: Discrete Logging

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 188   Solved: 131
[ Submit][ Status]

Description

Given a prime P, 2 <= P < 231, an integer B, 2 <= B < P, and an integer N, 2 <= N < P, compute the discrete logarithm of N, base B, modulo P. That is, find an integer L such that

    BL == N (mod P)

Input

Read several lines of input, each containing P,B,N separated by a space, 

Output

for each line print the logarithm on a separate line. If there are several, print the smallest; if there is none, print "no solution".

The solution to this problem requires a well known result in number theory that is probably expected of you for Putnam but not ACM competitions. It is Fermat's theorem that states

   B(P-1) == 1 (mod P)

for any prime P and some other (fairly rare) numbers known as base-B pseudoprimes. A rarer subset of the base-B pseudoprimes, known as Carmichael numbers, are pseudoprimes for every base between 2 and P-1. A corollary to Fermat's theorem is that for any m

   B(-m) == B(P-1-m) (mod P) .

Sample Input

5 2 1
5 2 2
5 2 3
5 2 4
5 3 1
5 3 2
5 3 3
5 3 4
5 4 1
5 4 2
5 4 3
5 4 4
12345701 2 1111111
1111111121 65537 1111111111

Sample Output

0
1
3
2
0
3
1
2
0
no solution
no solution
1
9584351
462803587


BSGS算法模板题。


BSGS算法就是求满足a^x=b (mod c)   (0<=x<c)的x的算法。【这里c为素数】


做法很简单:

设m=ceil(sqrt(c))  x=i*m+j  那么a^x=(a^m)^i*a^j


枚举i,可以在O(1)时间得出j。


如何在O(1)时间求出j?


设d=(a^m)^i 那么d*a^j=b (mod c),求出d的乘法逆元,那么就可以求出a^j%c。


可以先把a^j用hash表预处理出来,然后O(1)就可以求出j。


整个算法的时间复杂度O(sqrt(c))

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#include <cmath>
#include <map>
#define LL long long
using namespace std;
map<LL,LL> mp;
LL pow(LL a,LL x,LL p)
{
	LL base=a,ans=1;
	while (x)
	{
		if (x&1LL) ans=(ans*base)%p;
		base=(base*base)%p;
		x>>=1LL;
	}
	return ans;
}
int main()
{
	LL p,a,b;
        while (scanf("%lld%lld%lld",&p,&a,&b)!=EOF)
	{
		mp.clear();
		a%=p;
		if (!a)
		{
			if (!b) puts("1");
			else puts("no solution");
			continue;
		}
		LL m=(LL)ceil(sqrt(p));
		LL now=1;
		for (int i=1;i<=m;i++)
		{
			now=(LL)(now*a)%p;
			if (!mp[now]) mp[now]=i;
		}
		LL ni=pow(a,p-m-1,p);
		bool f=false;
		mp[1]=0;
		for (int i=0;i<m;i++)
		{
			if (mp.count(b))
			{
				printf("%lld\n",i*m+mp[b]);
				f=true;
				break;
			}
			b=(b*ni)%p;
		}
		if (!f)
			puts("no solution");
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值