Ellipse
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1358 Accepted Submission(s): 532
Problem Description
Math is important!! Many students failed in 2+2’s mathematical test, so let's AC this problem to mourn for our lost youth..
Look this sample picture:
A ellipses in the plane and center in point O. the L,R lines will be vertical through the X-axis. The problem is calculating the blue intersection area. But calculating the intersection area is dull, so I have turn to you, a talent of programmer. Your task is tell me the result of calculations.(defined PI=3.14159265 , The area of an ellipse A=PI*a*b )
Look this sample picture:
A ellipses in the plane and center in point O. the L,R lines will be vertical through the X-axis. The problem is calculating the blue intersection area. But calculating the intersection area is dull, so I have turn to you, a talent of programmer. Your task is tell me the result of calculations.(defined PI=3.14159265 , The area of an ellipse A=PI*a*b )
Input
Input may contain multiple test cases. The first line is a positive integer N, denoting the number of test cases below. One case One line. The line will consist of a pair of integers a and b, denoting the ellipse equation
, A pair of integers l and r, mean the L is (l, 0) and R is (r, 0). (-a <= l <= r <= a).
Output
For each case, output one line containing a float, the area of the intersection, accurate to three decimals after the decimal point.
Sample Input
2 2 1 -2 2 2 1 0 2
Sample Output
6.283 3.142
Author
威士忌
Source
Recommend
lcy
Simpson积分。
这道题中椭圆公式为x/a^2+y/b^2=1 因此f(x)=2*b*sqrt(1-x^2/a^2)
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <cstdio>
#define eps 1e-9
using namespace std;
double a,b,l,r;
double F(double x)
{
return 2*b*sqrt((double)1-x*x/(a*a));
}
double Calc(double l,double r)
{
double m=(l+r)/(double)2;
return (r-l)*(F(l)+(double)4*F(m)+F(r))/(double)6;
}
double Simpson(double l,double r)
{
double m=(l+r)/(double)2;
double fl=Calc(l,m),fr=Calc(m,r);
if (fabs(fl+fr-Calc(l,r))<eps) return fl+fr;
return Simpson(l,m)+Simpson(m,r);
}
int main()
{
int T;
scanf("%d",&T);
while (T--)
{
scanf("%lf%lf%lf%lf",&a,&b,&l,&r);
printf("%.3lf\n",Simpson(l,r));
}
return 0;
}
WA是因为精度不够。