1029. Median (25)

8 篇文章 0 订阅

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.

Sample Input
4 11 12 13 14
5 9 10 15 16 17
Sample Output
13
本题用到merge函数

merge函数的作用是:将两个有序的序列合并为一个有序的序列。函数参数:merge(first1,last1,first2,last2,result,cmp);

//firs1t为第一个容器的首迭代器,last1为第一个容器的末迭代器,first2为第二个容器的首迭代器,last2为容器的末迭代器,result为存放结果的容器的一个迭代器(begin()或任何一个位置),cmp为比较函数(可略写,默认为合并为一个升序序列)。

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std; 
vector<long long>a,b,c;
int main(){
	int m,n,tmp;
	cin>>m;
	for(int i=0;i<m;i++)
	{
		cin>>tmp;
		a.push_back(tmp);
	}
	cin>>n;
	for(int i=0;i<n;i++)
	{
		cin>>tmp;
		b.push_back(tmp);
	}
	c.resize(m+n);
	merge(a.begin(),a.end(),b.begin(),b.end(),c.begin());
	if((m+n)%2==0)	
		cout<<c[(m+n)/2-1]<<endl;
	else
		cout<<c[(m+n)/2]<<endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值