Travel Plan (30)

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40

这个题不想用dijkstra算法,就写了个DFS,没想到竟然AC了

#include<iostream>
#include<algorithm>

using namespace std; 
int edge[501][501]={{0}};//纪录每条边的距离
int visited[501]={0};//记录每个点是否被访问
int cost[501][501]={{0}};//记录每条边的价值
int path[501];//暂时储存路径的数组
int bestp[501];//最优路径
int n,m,s,d,mindis=99999999,mincost=99999999,k=0,num;//n,m,s,d为要求数组,mindis为最短距离,mincost为最小花费,k用来暂时记录路径顶点个数,num记录最优路径顶点的个数
void DFS(int t,int dis,int cos)
{
	if(dis>mindis)
		return;
	if(t==d)
	{
		if(dis<mindis||dis==mindis&&cos<mincost)//如果找到最短路径,或等长路径但花费最少
		{
			for(int i=0;i<k;i++)
				bestp[i]=path[i];//保存路径
			num=k;//保存路径点的个数
			mindis=dis;//保存最短路径长
			mincost=cos;//保存最少花费
		}
		return;//一定要return
	}
	for(int i=0;i<n;i++)
	{
		if(!visited[i]&&edge[t][i])
		{
			visited[i]=1;
			path[k++]=i;
			DFS(i,dis+edge[t][i],cos+cost[t][i]);
			visited[i]=0;//类似于回溯,千万不要忘记
			k--;
		}
	}
}
int main(){
	int v1,v2,dis,val;
	cin>>n>>m>>s>>d;
	for(int i=0;i<m;i++)
	{
		cin>>v1>>v2>>dis>>val;
		edge[v1][v2]=edge[v2][v1]=dis;
		cost[v1][v2]=cost[v2][v1]=val;
	}
	DFS(s,0,0);
	cout<<s;
	for(int i=0;i<num;i++)
		cout<<" "<<bestp[i];
	cout<<" "<<mindis<<" "<<mincost<<endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值