杭电OJ 1001Sum Problem

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 410430    Accepted Submission(s): 103191



Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate (计算) SUM(n) = 1 + 2 + 3 + ... + n.
 

Input
The input (投入) will consist of a series of integers (整数) n, one integer per line.
 

Output
For each case, output (输出) SUM(n) in one line, followed by a blank line. You may assume (承担) the result will be in the range of 32-bit signed integer.
 

Sample Input
  
  
1 100
Sample Output
  
  
1 5050
Author
DOOM III
# include <stdio.h>

int main (void)
{
    int n, i;
    int Sum;
    while (scanf("%d", &n)!=EOF)
    {
        Sum = 0;
        for (i = 1; i <= n; i++)
            Sum+=i;
        printf ("%d\n\n", Sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值