杭电oj第1001题—— Sum Problem

题述如下

Problem Description
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 
Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer. 
//注意,此处要求每个输出占一行,之后还需空一行,即输出需要两个“\n”

Sample Input
1
100

Sample Output
1
5050

自编代码如下:

#include<stdio.h>

int main(int argc, char **argv)
{
    int i,n,s;
    i=0,n=0,s=0;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0; i<=n; i++)
        {
            s+=i;
        }
        // 此处两个“\n”为题目要求的,否则会出现Presentation Error 
        printf("%d\n\n",s);    
        s=0;
    }
    return 0;
}

总结:

  1. 英语:读懂题目很重要;
  2. 注释:oj中使用“//”注释时,若注释过长,则会出compilation error,建议长注释使用“/*   */”。
  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值