甲 1053 Path of Equal Weight

题目描述

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

 

样例输入 

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

样例输出 

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

Key 

题目大意:给定一棵树和每个结点的权值,求所有从根结点到叶子结点的路径,使得每条路径上的结点的权值之和等于S。如果存在多条满足要求的路径,则按照路径的非递增顺序输出。

首先给每个结点的孩子降序排列,然后进行深搜,用一个数组记录路径上结点的编号。

#include <iostream>
#include <algorithm>
#include <cstring>
#include <vector>
using namespace std;
int N,M,S,p[101];

struct node
{
	int data;
	vector<int> child;
}a[101];

bool cmp(int x,int y)
{
	return a[x].data>a[y].data;
}

void dfs(int index,int numNode,int sum)
{
	p[numNode]=index;  //记录路径的编号 
	if(sum>S) return;  //如果根节点就大于给定常数,则返回 
	else if(sum==S)
	{
		if(a[index].child.size()!=0) return;
		for(int i=0;i<=numNode;i++)
		{
			cout<<a[p[i]].data;
			if(i!=numNode) cout<<" ";
		}
		cout<<endl;
	}
	else
	{
		for(int i=0;i<a[index].child.size();i++)
		{
			int pid=a[index].child[i];
			int b=a[pid].data;
			if(sum+b<=S)              //剪枝优化,小于等于目标值才向下搜索 
			{
				dfs(pid,numNode+1,sum+b);
			}
		}
	}
}

int main()
{
	int id,t,cid;
	cin>>N>>M>>S;
	for(int i=0;i<N;i++)
	{
		cin>>a[i].data;
	}
	for(int i=0;i<M;i++)
	{
		cin>>id>>t;
		while(t--)
		{
			cin>>cid;
			a[id].child.push_back(cid);
		}
		sort(a[id].child.begin(),a[id].child.end(),cmp);
	}
	dfs(0,0,a[0].data);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值