使用bottom navigation bar时遇到的问题

1、需要导入bottom-navigation-bar-1.2.0包。即在build.gradle的dependencies中添加语句:

compile‘com.ashokvarma.android:bottom-navigation-bar:1.2.0'

2、使用fragment时遇到错误8. wrong 2nd argument type found 'android.app.Fragment.' required 'Android.support.v4.app.Fragment'

如果导入的是Android.app.Fragment’包(即本地的jar包)
import android.app.Fragment;
那么在获得FragmentManager时,使用的应该是
FragmentManager fm = getFragmentManager();,对应的fragment也要导入对应的包!



如果你导入的是android.support.v4.app.Fragment.包(即v4包)
import android.support.v4.app.Fragment;
那么在获得FragmentManager时,使用的应该是
FragmentManager fm = getSupportFragmentManager();
对应的fragment也要导入对应的包!


一定要注意你所继承的fragment,导入的是哪个包!

这个讲解了fragment,学习学习

相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页