HDU 5113 Black And White (搜索DFS)2014ICPC北京站现场赛

Black And White

                                                                       Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
                                                                                                     Total Submission(s): 1869    Accepted Submission(s): 512
                                                                                                                                           Special Judge


Problem Description
In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly c i cells.

Matt hopes you can tell him a possible coloring.
 

Input
The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers c i (c i > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c 1 + c 2 + · · · + c K = N × M .
 

Output
For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1). 

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.
 

Sample Input
  
  
4 1 5 2 4 1 3 3 4 1 2 2 4 2 3 3 2 2 2 3 2 3 2 2 2
 

Sample Output
  
  
Case #1: NO Case #2: YES 4 3 4 2 1 2 4 3 4 Case #3: YES 1 2 3 2 3 1 Case #4: YES 1 2 2 3 3 1
 

题意:在一个N*M大小的方格中让你随机的涂满K种颜色,第i种颜色需要涂Ci个格子,满足所有颜色一定能涂满整个方格。

分析:在做这道题的时候有两种想法,一种是构造,一种是搜索,构造有点复杂,又考虑到N最大为5,然后果断选择了搜索。但是搜索的时候一定要进行剪枝,否则一定会TLE。当然剪枝也是有技巧的。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <deque>
#include <list>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <cctype>
#include <numeric>
#include <iomanip>
#include <bitset>
#include <sstream>
#include <fstream>
#define debug "output for debug\n"
#define pi (acos(-1.0))
#define eps (1e-8)
#define inf 0x3f3f3f3f
#define ll long long int
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
using namespace std;
const int mod = 1000000007;
const int Max = 100005;
int t,n,m,k;
int col[30];
int mp[30][30];
int flag;
bool check(int x,int y,int color)
{
    if(x-1>0&&mp[x-1][y]==color)
        return false;
    if(y-1>0&&mp[x][y-1]==color)
        return false;
    return true;
}
bool dfs(int x,int y)
{
    int tmp=(n*m-((x-1)*m+y-1)+1)/2;///在这里进行了剪枝,比在选颜色的for循环里剪要优化很多,自己可以试试,另外如果对颜色数组按照大小排序会更快。
    for(int i=1;i<=k;i++)
    {
        if(tmp<col[i])
            return false;
    }
    for(int i=1; i<=k; i++)
    {
        if(col[i]>0&&check(x,y,i))
        {
            col[i]--;
            mp[x][y]=i;
            if(x==n&&y==m)
                return true;
            if(y+1<=m)
            {
                if(dfs(x,y+1))
                    return true;
            }
            else
            {
                if(x+1<=n)
                {
                    if(dfs(x+1,1))
                        return true;
                }
            }
            col[i]++;
            mp[x][y]=0;
        }
    }
    return false;
}
int main()
{
    cin>>t;
    int cnt=1;
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&k);
        memset(mp,0,sizeof mp);
        flag=0;
        int ma=0;
        for(int i=1; i<=k; i++)
        {
            scanf("%d",&col[i]);
            ma=max(ma,col[i]);
        }
        printf("Case #%d:\n",cnt++);
        if(ma>(n*m+1)/2)
        {
            puts("NO");
            continue;
        }
        if(dfs(1,1))
        {
            puts("YES");
            for(int i=1; i<=n; i++)
            {
                for(int j=1; j<m; j++)
                    printf("%d ",mp[i][j]);
                printf("%d\n",mp[i][m]);
            }
        }
        else
            puts("NO\n");
    }
    return 0;
}

题目链接: 点击打开链接


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值