BFS-POJ-3414-Pots

Pots
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11798 Accepted: 4992 Special Judge
Description

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

FILL(i) fill the pot i (1 ≤ i ≤ 2) from the tap;
DROP(i) empty the pot i to the drain;
POUR(i,j) pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).
Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers A, B, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input

3 5 4
Sample Output

6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)

由于是求最小的操作步数,广搜就能解决。同时由于数据比较小,用visit数组去重。在bfs的同时保存路径即可。

//
//  main.cpp
//  简单搜索-H-Pots
//
//  Created by 袁子涵 on 15/8/2.
//  Copyright (c) 2015年 袁子涵. All rights reserved.
//

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>

using namespace std;

int A,B,C;
int sum;
int flag=0;
bool visit[101][101];

typedef struct data
{
    int op;
    int x,y;
    int a,b;
    int step;
    struct data  *father;
    struct data  *next;
}Data;

typedef struct queue
{
    int head,tail;
    Data data[10001];
}Queue;

Queue q;
Data *m,*n;

bool queue_empty()
{
    if (q.head==q.tail) {
        flag=-1;
        return 0;
    }
    return 1;
}

void queue_init()
{
    q.head=0;
    q.tail=0;
}

void queue_En(Data t)
{
    visit[t.a][t.b]=1;
    q.data[q.tail++]=t;
}

Data queue_De()
{
    Data t;
    t=q.data[q.head++];
    return t;
}

void bfs()
{
    Data t,k;
    t.step=0;
    t.a=0;
    t.b=0;
    t.x=0;
    t.y=0;
    t.op=0;
    t.father=NULL;
    t.next=NULL;
    queue_init();
    queue_En(t);
    while (queue_empty()) {
        t=queue_De();
        if (t.a==C || t.b==C) {
            sum=t.step;
            *m=t;
            flag=1;
            return;
        }
        //FILL
        if (t.a<A && t.b<B) {
            k=t;
            k.a=A;
            k.op=1;
            k.x=1;
            k.father=&q.data[q.head-1];
            k.step++;
            if (!visit[k.a][k.b])
                queue_En(k);
        }
        if (t.b<B && t.a<A) {
            k=t;
            k.b=B;
            k.op=1;
            k.x=2;
            k.father=&q.data[q.head-1];
            k.step++;
            if (!visit[k.a][k.b])
                queue_En(k);
        }
        //DROP
        if (t.a>0 && t.b>0) {
            k=t;
            k.a=0;
            k.op=2;
            k.x=1;
            k.father=&q.data[q.head-1];
            k.step++;
            if (!visit[k.a][k.b])
                queue_En(k);
        }
        if (t.b>0 && t.a>0) {
            k=t;
            k.b=0;
            k.op=2;
            k.x=2;
            k.father=&q.data[q.head-1];
            k.step++;
            if (!visit[k.a][k.b])
                queue_En(k);
        }
        //POUR
        if (t.a>0 && t.b<B) {
            k=t;
            k.op=3;
            k.x=1;
            k.y=2;
            int w1;
            if (k.a>=B-k.b) {
                w1=B-k.b;
                k.a-=w1;
                k.b=B;
            }
            else
            {
                k.b+=k.a;
                k.a=0;
            }
            k.father=&q.data[q.head-1];
            if (!visit[k.a][k.b])k.step++;
                queue_En(k);
        }
        if (t.b>0 && t.a<A) {
            k=t;
            k.op=3;
            k.x=2;
            k.y=1;
            int w1;
            if (k.b>=A-k.a) {
                w1=A-k.a;
                k.b-=w1;
                k.a=A;
            }
            else
            {
                k.a+=k.b;
                k.b=0;
            }
            k.father=&q.data[q.head-1];
            k.step++;
            if (!visit[k.a][k.b])
                queue_En(k);
        }
    }

}

int main(int argc, const char * argv[]) {
    cin >> A >> B >> C;
    if (C > A && C > B) {
        cout << "impossible" << endl;
        return 0;
    }
    sum=-1;
    m=(Data*)malloc(sizeof(Data));
    n=(Data*)malloc(sizeof(Data));
    bfs();
    if (flag!=-1) {
        cout << sum << endl;
        n=m->father;
        while (n!=NULL) {
            n->next=m;
            m=n;
            n=m->father;
        }
        m=&q.data[0];
        n=m->next;
        while (m!=NULL) {
            n=m->next;
            switch (m->op) {
                case 1:
                    printf("FILL(%d)\n",m->x);
                    break;
                case 2:
                    printf("DROP(%d)\n",m->x);
                    break;
                case 3:
                    printf("POUR(%d,%d)\n",m->x,m->y);
                    break;
                default:
                    break;
            }
            m=n;
        }
    }
    if (flag==-1)
    {
        cout << "impossible" << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值