Phalanx
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 770 Accepted Submission(s): 357
Problem Description
Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC.
A phalanx is a matrix of size n*n, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position.
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs.
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix:
cbx
cpb
zcc
Input
There are several test cases in the input file. Each case starts with an integer n ( 0 < n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.
Output
Each test case output one line, the size of the maximum symmetrical sub- matrix.
Sample Input
3
abx
cyb
zca
4
zaba
cbab
abbc
cacq
0
Sample Output
3
3
Source
2009 Multi-University Training Contest 5 - Host by NUDT
题目翻译:几天是建军节,我们可爱的解放军叔叔们正忙着准备PRC60周年庆上的方阵。一个方阵是一个n x n的矩阵,每一个元素是一个a~z或A~Z的字符,表示着站在该位置的一种军种。因为一些特殊原因,必须找到最大的对称子矩阵,然后毫无疑问,这个光荣而艰巨的任务就交给我们ACMer了。一个对称矩阵满足:以左下到右上的对角线为对称轴的元素都相同。举个栗子,这是一个3x3的对称矩阵:
cbx
cpb
zcc
——终——
用dp[i][j]来表示以(i,j)为对称轴最下方端点,能够找到的最大对称子矩阵的大小。
那么以(i,j)右上方的点(i-1,j+1)为对称轴最下方端点,能够找到的最大对称子矩阵的大小是dp[i-1][j+1]。
那么令temp=dp[i-1][j+1],然后k=1~temp循环一次,对比(i-k,j)与(i,j+k)是否相等,不相等就退出循环,此时1~k中的(i-k,j)与(i,j+k)一定是相等的。
那么由于dp[i-1][j+1]本身已经满足其他位置的元素相等,所以现在dp[i][j]=max(dp[i][j],temp+1)。
从第二排开始所有位置都DP一次,记录返回的最大值输出即可。
//
// main.cpp
// 基础DP1-Q-Phalanx
//
// Created by 袁子涵 on 15/10/28.
// Copyright © 2015年 袁子涵. All rights reserved.
//
// 2449ms 7500KB
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>
#define MAX 1005
using namespace std;
char phalanx[MAX][MAX];
int dp[MAX][MAX],n;
bool visit[MAX][MAX];
int DP(int x,int y)
{
if (x<1 || y<1 || x>n || y>n) {
return 0;
}
if (visit[x][y]) {
return dp[x][y];
}
int temp,flag=0;
temp=DP(x-1, y+1);
for (int i=1; i<=temp; i++) {
if (phalanx[x-i][y]!=phalanx[x][y+i]) {
break;
}
flag++;
}
if (flag) {
dp[x][y]=max(dp[x][y],flag+1);
}
visit[x][y]=1;
return dp[x][y];
}
int main(int argc, const char * argv[]) {
while (scanf("%d",&n)!=EOF && n!=0) {
for (int i=1; i<=n; i++) {
int c;
while((c = getchar()) != '\n' && c != EOF);
for (int j=1; j<=n; j++) {
scanf("%c",&phalanx[i][j]);
}
}
for (int i=1; i<=n; i++) {
for (int j=1; j<=n; j++) {
dp[i][j]=1;
visit[i][j]=0;
}
}
for (int i=1; i<=n; i++) {
visit[1][i]=1;
}
int out =1;
for (int i=2; i<=n; i++) {
for (int j=1; j<=n; j++) {
out=max(out,DP(i, j));
}
}
cout << out << endl;
}
return 0;
}