数位DP-POJ-3252-Round Numbers

Round Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10811 Accepted: 3974
Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone’ (also known as ‘Rock, Paper, Scissors’, ‘Ro, Sham, Bo’, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can’t even flip a coin because it’s so hard to toss using hooves.

They have thus resorted to “round number” matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both “round numbers”, the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a “round number” if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many “round numbers” are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.
Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish
Sample Input

2 12
Sample Output

6
Source

USACO 2006 November Silver


题意:
给定一个区间[a,b],要求找出这个区间内Round Number的数量。
满足以下条件的数被称作Round Number:
将数转换为二进制,它为1的数位个数小于或等于它为0的数位个数。


分析:
此题明显满足区间减法,即result[a,b]=result[1,b]-result[1,a],所以要解决的问题变成了如何求出[1,n]这个区间中Round Number的数量。
首先我们预处理出dp[0][size][num]和dp[1][size][num],其中dp[0][size][num]代表的是长度为size的拥有num个1的二进制数的个数,dp[1][size][num]代表的是0~111…(size个1)内拥有num个1的二进制数的个数。
那么很容易得到
dp[0][size][num]=dp[0][size-1][num-1];
dp[1][size][num]=dp[1][size-1][num]+dp[1][size-1][num-1]。
由此求[1,n]中Round Number数量时,先将n处理为二进制存放在数组num[]里,同时得出长度size,并初始化sum=0,pre=0,令最大出现1个数为max。
对于n,先找到它在num中的最高位,也就是num[size],这里一定是为1的,那么先加上1~111…(size-1个1)内的Round Number数量。
然后让pre++,即当前位之前出现的1的个数加一。
之后从size-1位开始处理到1位,先判断num[now]是否为1,如果不为1就跳过到下一位;如果为1,那么就加上dp[1][now-1][0~max-pre],即now位为0,后面能够出现的Round Number数量,加后别忘了再把pre++,因为num[now]是1。
附上代码。


//
//  main.cpp
//  数位DP-E-Round Numbers
//
//  Created by 袁子涵 on 15/11/4.
//  Copyright © 2015年 袁子涵. All rights reserved.
//
//  0ms    716KB

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>

using namespace std;
long long int start,finish;
long long int dp[2][35][35];

void handle()
{
    memset(dp, 0, sizeof(dp));
    dp[1][0][0]=1;
    dp[1][1][0]=1;
    dp[1][1][1]=1;
    for (int i=2; i<33; i++) {
        for (int j=i; j>=0; j--) {
            dp[1][i][j]=dp[1][i-1][j]+dp[1][i-1][j-1];
        }
    }
    dp[0][1][1]=1;
    for (int i=2; i<33; i++) {
        dp[0][i][1]=1;
        for (int j=i; j>1; j--) {
            dp[0][i][j]=dp[1][i-1][j-1];
        }
    }
}

long long int DP(long long int x)
{
    int num[35],size=0,pre=0;
    long long int sum=0;
    memset(num, 0, sizeof(num));
    while (x) {
        num[++size]=x%2;
        x/=2;
    }
    for (int i=size-1; i>=1; i--) {
        for (int j=i/2; j>0; j--) {
            sum+=dp[0][i][j];
        }
    }
    pre++;
    for (int i=size-1; i>=1; i--) {
        if (num[i]==1) {
            for (int j=(size/2)-pre; j>=0; j--) {
                sum+=dp[1][i-1][j];
            }
            pre++;
        }
    }
    return sum;
}

int main(int argc, const char * argv[]) {
    cin >> start >> finish;
    handle();
    start=DP(start);
    finish=DP(finish+1);
    cout << finish-start << endl;
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值