1619: [Usaco2008 Nov]Guarding the Farm 保卫牧场
Time Limit: 5 Sec Memory Limit: 64 MBSubmit: 913 Solved: 411
[ Submit][ Status][ Discuss]
Description
The farm has many hills upon which Farmer John would like to place guards to ensure the safety of his valuable milk-cows. He wonders how many guards he will need if he wishes to put one on top of each hill. He has a map supplied as a matrix of integers; the matrix has N (1 < N <= 700) rows and M (1 < M <= 700) columns. Each member of the matrix is an altitude H_ij (0 <= H_ij <= 10,000). Help him determine the number of hilltops on the map. A hilltop is one or more adjacent matrix elements of the same value surrounded exclusively by either the edge of the map or elements with a lower (smaller) altitude. Two different elements are adjacent if the magnitude of difference in their X coordinates is no greater than 1 and the magnitude of differences in their Y coordinates is also no greater than 1.
农夫JOHN手头有一个用数字矩阵来表示地形的地图。这个矩阵有N行(1 < N < = 700)和M列( 1 < M < = 700) 。矩阵中的每个元素都有一个值H_ij(0 < = H_ij < =10,000)来表示该地区的海拔高度。请你帮助他统计出地图上到底有多少个小山丘。 小山丘的定义是:若地图中一个元素所邻接的所有元素都比这个元素高度要小(或它邻接的是地图的边界),则该元素和其周围所有按照这样顺序排列的元素的集合称为一个小山丘。这里邻接的意义是:若一个元素与另一个横坐标纵坐标和它的横纵坐标相差不超过1,则称这两个元素邻接。 问题名称:guard 输入格式: 第一行:两个由空格隔开的整数N和M 第二行到第N+1行:第I+1行描述了地图上的第I行,有M个由空格隔开的整数:H_ij. 输入样例:(guard.in): 8 7 4 3 2 2 1 0 1 3 3 3 2 1 0 1 2 2 2 2 1 0 0 2 1 1 1 1 0 0 1 1 0 0 0 1 0 0 0 0 1 1 1 0 0 1 2 2 1 1 0 0 1 1 1 2 1 0 输出格式: 第一行:小山丘的个数 输出样例:(guard.out): 3 输出样例解释: 地图上有三个小山丘:每个小山丘的山峰位置分别在左上角(高度为4),右上角(高度为1)和底部(高度为2)。
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes row i of the matrix with M space-separated integers: H_ij
Output
* Line 1: A single integer that specifies the number of hilltops
Sample Input
Sample Output
所有点按高度排序,从最高的点开始搜,类似灌水的过程
#include<stdio.h>
#include<algorithm>
using namespace std;
typedef struct Point
{
int h;
int x, y;
bool operator < (const Point &b) const
{
if(h>b.h)
return 1;
return 0;
}
}Point;
Point s[500005];
int n, m, a[705][705], flag[705][705];
int dir[8][2] = {1,0,0,1,-1,0,0,-1,1,-1,-1,1,1,1,-1,-1};
void Sech(int x, int y)
{
int dx, dy, i;
flag[x][y] = 1;
for(i=0;i<=7;i++)
{
dx = x+dir[i][0];
dy = y+dir[i][1];
if(dx<1 || dx>n || dy<1 || dy>m || flag[dx][dy] || a[dx][dy]>a[x][y])
continue;
Sech(dx, dy);
}
}
int main(void)
{
int i, j, ans, cnt = 0;
scanf("%d%d", &n, &m);
for(i=1;i<=n;i++)
{
for(j=1;j<=m;j++)
{
scanf("%d", &a[i][j]);
s[++cnt].x = i, s[cnt].y = j;
s[cnt].h = a[i][j];
}
}
sort(s+1, s+cnt+1);
ans = 0;
for(i=1;i<=cnt;i++)
{
if(flag[s[i].x][s[i].y]==0)
{
Sech(s[i].x, s[i].y);
ans++;
}
}
printf("%d\n", ans);
return 0;
}