Description
贝茜在珠宝店闲逛时,买到了一个中意的手镯。很自然地,她想从她收集的 N(1 <= N <= 3,402)块宝石中选出最好的那些镶在手镯上。对于第i块宝石,它的重量为W_i(1 <= W_i <= 400),并且贝茜知道它在镶上手镯后能为自己增加的魅力值D_i(1 <= D_i <= 100)。由于贝茜只能忍受重量不超过M(1 <= M <= 12,880)的手镯,她可能无法把所有喜欢的宝石都镶上。 于是贝茜找到了你,告诉了你她所有宝石的属性以及她能忍受的重量,希望你能帮她计算一下,按照最合理的方案镶嵌宝石的话,她的魅力值最多能增加多少。
Input
-
第1行: 2个用空格隔开的整数:N 和 M
-
第2…N+1行: 第i+1行为2个用空格隔开的整数:W_i、D_i,分别为第i块宝石 的重量与能为贝茜增加的魅力值
Output -
第1行: 输出1个整数,表示按照镶嵌要求,贝茜最多能增加的魅力值
Sample Input
4 6
1 4
2 6
3 12
2 7
输入说明:
贝茜收集了4块宝石,她能忍受重量最大为6的手镯。
Sample Output
23
输出说明:
贝茜把除了第二块宝石的其余所有宝石都镶上手镯,这样她能增加
4+12+7=23的魅力值,并且所有宝石的重量为1+2+3 <= 6,同样符合要求。
题解:
明显的01背包,dp[i][j]表示前i个宝石,在可承受重量为j的情况下最大的魅力。
那么dp[i][j]=max(dp[i-1][j],dp[i-1][j-W[i]]+D[i]),当然,对于j<W[i]的情况,dp[i][j]=dp[i-1][j]。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <string>
#include <queue>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;
typedef struct node
{
int w,d;
}node;
int n,m,now,last,dp[2][13000];
node stone[3500];
int main()
{
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
scanf("%d%d",&stone[i].w,&stone[i].d);
now=1,last=0;
for(int i=1;i<=n;i++)
{
for(int j=0;j<=m;j++)
{
if(j>=stone[i].w)
dp[now][j]=max(dp[last][j],dp[last][j-stone[i].w]+stone[i].d);
else
dp[now][j]=dp[last][j];
}
if(now==1)
now=0,last=1;
else
now=1,last=0;
}
cout << dp[last][m] << endl;
return 0;
}